Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Posts: 271
Registered: ‎01-21-2013
My Device: BB10 Dev Aplha
My Carrier: -

App does not works for some users

I have my Adobe AIR application in Blackberry App World which is BFB certified and I have two versions of it, one for Z10 and other for Q10. World Clock Built for BlackBerry

 

I have tested both the applications on my LE Z10 and Dev C and it works fine and also being approved by App World means it is also working fine with BB World testing devices.

 

However I am getting many complaints from users that the app does not work, mostly on Q10 devices. All of them have the latest BB10 OS, which has been downloaded from authentic source and even they are facing the issues. The app uses online web services while loading and users complaint that the app does not go beyond the initial loading and is stuck.

 

I am clueless as what might be the problem and don’t know whom to contact from Blackberry. Can anyone please advise how to go about this? Users are posting comments for my app as it does not work and it is hampering the downloads and revenue in turn. The frustrating part is I am not able to help any of my customer. 

Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: App does not works for some users

If you are making network requests, are you capturing errors when there is no network?

Also, if you are accessing the shared file system, are you checking that you have permission to read and write from there?

These are the most common runtime issues.
Developer
Posts: 271
Registered: ‎01-21-2013
My Device: BB10 Dev Aplha
My Carrier: -

Re: App does not works for some users

I am not using permission, the only permission used is Calendar and it doesn't have anything to do with initial app loading.

For Internet, I even checked without sim on my Dev c and the app worked with default data, so I guess that won't be an issue.

The same version is working fine on most of Q10, but I also have received about 10 complaints of it not working. This won't happen all of them don't have Internet connection.

I don't have Q10 to test on, can anyone please check with actual Q10, and not Dev C.

The app would be placed on BlackBerry World carousel and I would not like to have these issues that Time and people complaining and rating badly.
Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: App does not works for some users

Have the user reinstall the app to see if that clears it up.