Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Posts: 50
Registered: ‎05-15-2012
My Device: PlayBook
My Carrier: no provider
Accepted Solution

Can I use Flash Builder 4.7 to develop OS 2.1 apps?

[ Edited ]

It seems that a minimum AIR SDK version it is working with is 3.4. I get a warning that AIR must be 3.1 when try to run my app on playbook. Tried forcing AIR to version 3.1 from this manual , but it doesn't help, it complains about wrong namespace.

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

Hi,

 

In Flash Builder 4.7 to get rid of that error just set your app.xml file to use 3.4. It will still compile 3.1.

 

<application xmlns="http://ns.adobe.com/air/application/3.4">

 

Cheers,

Dustin

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Developer
Posts: 50
Registered: ‎05-15-2012
My Device: PlayBook
My Carrier: no provider

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

[ Edited ]

I've changed 3.1 to 3.4 :

 

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<application xmlns="http://ns.adobe.com/air/application/3.4">

 

and now I'm getting this error:

 

Error occurred while packaging the application:

Packaging failed:1
C:\Users\Alex\AppData\Local\Temp\bar-app3712331318498963496.xml: error 102: Invalid namespace http://ns.adobe.com/air/application/3.4
Error: AIR validation failed

Developer
Posts: 50
Registered: ‎05-15-2012
My Device: PlayBook
My Carrier: no provider

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

I used this manual to setup FB 4.7:

https://developer.blackberry.com/air/documentation/playbook/ww_air_getting_started/install_bbtos_sdk...

 

I'm setting up BlackBerry Tablet OS SDK, not BB10 SDK

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

Just want to provide an update on this.

 

I'm getting the same error and have passed it on to the tooling team. We're looking into it.

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

Hi,

 

So right now the workaround is to delete or rename the adt.jar file from

<install_dir>\blackberry-tablet-sdk-2.1.0\lib directory

 

Please note that this file is hidden by default.

 

We're updating the documentation.

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Developer
Posts: 116
Registered: ‎11-18-2010
My Device: BlackBerry PlayBook
My Carrier: null

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

Hello dear developers.

I meet same problem when upgrate FlashBuilder to version 4.7. These things are very upset me as FlashBuilder is not a cheap thing. I set AIR version to 3.4 (also i download 3.5 and try with it also) but have no chance to run application. It takes long time to discover device - upload application - connect to running application ..... and finaly after a minute just saying could not connect to application. The icon is exist at playbook but when I tap it - nothing happened.

Can someone help me with this issue?

Developer
Posts: 116
Registered: ‎11-18-2010
My Device: BlackBerry PlayBook
My Carrier: null

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

Ok, today I have done a clean of all adobe products, install all of the once again.

I can say for 100% that there is a problem with FlashBuilder 4.7 and SDK 2.1.

More over, it takes much longer time comparing with FlashBuilder 4.5 to discover device / upload device!

The application is upload to the device, trying to run and close. There is no possible even to get an error or a reason of such behavior.

Does any one meet same problem ?

It is very important issue.

Regular Visitor
Posts: 1
Registered: ‎12-29-2012
My Device: Playbook
My Carrier: o2

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

I have same problem. When the application is upload to device, tries to run and close without any error message.

I tried to force AIR 3.1 - https://developer.blackberry.com/air/documentation/bb10/gsg_change_runtime_fb.html

but still without any success.

Developer
Posts: 116
Registered: ‎11-18-2010
My Device: BlackBerry PlayBook
My Carrier: null

Re: Can I use Flash Builder 4.7 to develop OS 2.1 apps?

Please try to use SDK 2.0 only as with 2.1 it doesn not work
http://monosnap.com/image/RXXqY7uLmmbn0d9iV35ZqLXUZ/