Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
Macil
Posts: 5
Registered: ‎12-08-2010
My Device: Not Specified

Cannot get Setup working with Flash Builder Burrito

Hello,

 

I'm starting to write my first application utilizing any sort of BB development tools. I'm coming from Android and I have several released applications in the Android Market that I'm looking to port over. However, I'm having so many issues getting setup it's ridiculous.

 

I have successfully completed the following:

 

- Download/Install Air 2.5 SDK, Playbook SDK

- Download/Install Flash Builder Burrito

- Download/Setup VMWare Fusion + Playbook Simulator

 

I started writing my first application and now I'm trying to actually debug it in the simulator, and that is where all of my trouble is starting. There is no debug or deploy launch configuration/perspective for the Playbook at all. There is a "Mobile" one, but it won't allow for any kind of launch. I've searched everywhere and cannot find any information on this at all. Any information on how to get this working would be great, as I'm really looking forward to developing on this platform, but so far it has been nothing but frustrating.

 

Thank you for any help.

- Macil.

New Developer
dkerr
Posts: 38
Registered: ‎12-01-2010
My Device: Playbook

Re: Cannot get Setup working with Flash Builder Burrito

Did you grab the 0.9.1 version of the BB SDK?  It is the only one that works with Burrito.

 

You should not need Air 2.5.  You should select the 4.5 sdk that installs with Burrito.

 

Don

Don Kerr
Manager, Space City Adobe User Group
Houston, Tx
www.spacecityaug.com
New Contributor
Macil
Posts: 5
Registered: ‎12-08-2010
My Device: Not Specified

Re: Cannot get Setup working with Flash Builder Burrito

Yes, I'm using the 0.9.1 sdk. All of the tools I downloaded came from the BB site, and I got them all yesterday, so they should be the most current.

Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Cannot get Setup working with Flash Builder Burrito

Hey Macil,

 

are you starting from scratch (new project) or using existing projects that were previously created using Flash Builder? also are you able to import and use the QNX libraries?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Contributor
pranaydalmia
Posts: 2
Registered: ‎04-13-2010
My Device: Cureve 8520

Re: Cannot get Setup working with Flash Builder Burrito

 


Macil wrote:

Hello,

 

I'm starting to write my first application utilizing any sort of BB development tools. I'm coming from Android and I have several released applications in the Android Market that I'm looking to port over. However, I'm having so many issues getting setup it's ridiculous.

 

I have successfully completed the following:

 

- Download/Install Air 2.5 SDK, Playbook SDK

- Download/Install Flash Builder Burrito

- Download/Setup VMWare Fusion + Playbook Simulator

 

I started writing my first application and now I'm trying to actually debug it in the simulator, and that is where all of my trouble is starting. There is no debug or deploy launch configuration/perspective for the Playbook at all. There is a "Mobile" one, but it won't allow for any kind of launch. I've searched everywhere and cannot find any information on this at all. Any information on how to get this working would be great, as I'm really looking forward to developing on this platform, but so far it has been nothing but frustrating.

 

Thank you for any help.

- Macil.


 

+1 to your problem buddy. You are not the only one facing this issue. Even i started off yesterday. Downloaded all the latest tools. But still cant run the application because the PlayBook configuration doesnt show up in the debug configurations list. Tried and tried. Now frustrated. If anyones got a workaround please update me. RIM you can help too..

Developer
willyyr
Posts: 229
Registered: ‎08-14-2009
My Device: Bold 9900, DevAlpha A

Re: Cannot get Setup working with Flash Builder Burrito

One thing that worked for me is installing the playbook sdk AFTER installig Burrito. Also try what Jrab mentioned and create a project from scratch like iN the tutorials and see if you have the Playbook option in the AS3 mobile projects. Some of us here had to reinstall several times before everything worked like it's supposed to. If you're on WIN make sure to run the installers as administrator. Is your simulator running already? Can you bring it into dev mode and ping it sucessfully?
Willy R.
-
If my post solved your problem, make it easier for others to find by Accepting it as a solution or provide a Kudo if it was helpful for you. Thanks.