Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
Posts: 4
Registered: ‎03-25-2013
My Device: Playbook
My Carrier: Voda
Accepted Solution

Developed a playbook app, now need guidance regarding targeting future devices.

Hi,

 

I have managed to develop a playbook app using FB 4.7, and Flex 4.6 (AIR 3.1). I'm using the latest SDK which is 2.1.0. So my question is, 

 

 

1- will my app only support 2.1.0+ version of playbook? or lower versions too?

 

 

2- can this same app support other QNX devices? if so, what are those devices (i see 4-5 devices in the add device form) and how can i make same app work on those platforms too.

 

 

3-My app is a children app where children will b able create avatars, now user generated content requirment in the submission form has 4-5 questions and i dont know what to write there, please advice! as my app shouldnt have any issue with 'creation of unethical content' because it children friendly, now i cant stop users to write something bad in hindi and post the image..

  

Thanks

Developer
Posts: 1,280
Registered: ‎03-03-2011
My Device: Playbook, Z10, Q10, Z30 with Files & Folders and Orbit of course
My Carrier: Vodafone

Re: Developed a playbook app, now need guidance regarding targeting future devices.


clozertou wrote:

Hi,

 

I have managed to develop a playbook app using FB 4.7, and Flex 4.6 (AIR 3.1). I'm using the latest SDK which is 2.1.0. So my question is, 

 

1- will my app only support 2.1.0+ version of playbook? or lower versions too?

 


As long as you don't use any 2.1.0-specific API's, it should run on 2.0.0. If it works OK in the AIR desktop runtime, it will almost certainly work on the device too. Note that most PlayBook users upgrade their OS quickly. There are very few people running older versions. See http://news.ebscer.com/2013/04/playbook-users-still-on-newest-os/

 


2- can this same app support other QNX devices? if so, what are those devices (i see 4-5 devices in the add device form) and how can i make same app work on those platforms too.


You'll need to adjust your user interface, graphics, splash screens and icons to work on different resolutions and aspect ratios. The new BB10 devices have 768x1280 and 720x720 pixel resolutions, and a much higher pixel density. Buttons would need to be about twice the size (in pixels). Try to avoid hard-coded absolute positions & sizes, and rely more on anchoring and percentage sizes. More info can be found here.

 

To test, you can configure your desktop AIR runtime to emulate different resolutions, or use the simulators. Or better still, try to get a real device.

 

The "other" devices are the BlackBerry Z10, Q10, Q5 (consumer) and Dev Alpha A/B/C (developer) devices. The rumoured  BlackBerry A10 may have a different resolution still.


3-My app is a children app where children will b able create avatars, now user generated content requirment in the submission form has 4-5 questions and i dont know what to write there, please advice! as my app shouldnt have any issue with 'creation of unethical content' because it children friendly, now i cant stop users to write something bad in hindi and post the image..


Don't know about this. Maybe ask this over in the BB World Developer forum.

Files & Folders, the unified file & cloud manager for PlayBook and BB10 with SkyDrive, SugarSync, Box, Dropbox, Google Drive, Google Docs. Free 3-day trial! - Jon Webb - Innovatology - Utrecht, Netherlands
New Contributor
Posts: 4
Registered: ‎03-25-2013
My Device: Playbook
My Carrier: Voda

Re: Developed a playbook app, now need guidance regarding targeting future devices.

Thanks a lot :smileyhappy:
Contributor
Posts: 10
Registered: ‎06-13-2011
My Device: PlayBook, Z10
My Carrier: Koodo

I cannot install the BlackBerryAir.app on Mac OSX 10.8.4

Hi 

 

I am a BB developer using the Flash Builder 4.7 IDE to develop cross platform AIR apps. I have updated to Fb 4.7, updated the Adobe AIR in Fb 4.7 to 3.7. When I try to add in suport for BB devices, either the Tablet (playbook) or the BB10 the installs always seems to freeze. 

The file 'BlackBerryAirSDK.app' nevers shows the disclaimer, licesne, or anything for that matter. It only shows a blank window with a glowing 'Next' button, which does nothing.

 

I have re downloaded the file 'BlackBerry-Air-SDK-Installer-3.2.0-Mac-201305291455.dmg' several times and always face the same issue. Any ideas what is going on?

 

Developer
Posts: 1,280
Registered: ‎03-03-2011
My Device: Playbook, Z10, Q10, Z30 with Files & Folders and Orbit of course
My Carrier: Vodafone

Re: I cannot install the BlackBerryAir.app on Mac OSX 10.8.4

Please start a new thread, this has nothing to do with this thread.

Files & Folders, the unified file & cloud manager for PlayBook and BB10 with SkyDrive, SugarSync, Box, Dropbox, Google Drive, Google Docs. Free 3-day trial! - Jon Webb - Innovatology - Utrecht, Netherlands