Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
dbigham
Posts: 552
Registered: ‎04-01-2009
My Device: Z10, PlayBook

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

I've tried manually adjusting the Playbook clock to match my PC, I've tried reinstalling the playbook with my PC set to UTC so that when I set my PC back to EST the clocks match, and neither seems to help. I'm using the command line with the -password option.

 

I've now reinstalled the playbook simulator about 4 times without any luck.

 

*Very* frustrating.

Contributor
quentin
Posts: 49
Registered: ‎11-18-2010
My Device: Flash Builder - PlayBook Simulator

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

Same here, this bug is horrible.

Developer
dooglehead
Posts: 26
Registered: ‎12-24-2010
My Device: Playbook

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

I also have this problem.  

 

I just submitted an update to my app without testing first because of this.  (I didn't change much, so hopefully I didn't screw something up.)

Developer
jonberry
Posts: 484
Registered: ‎07-17-2008
My Device: Not Specified

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

I'm getting the same error.

 

I had this working last night but now it just bombs out.

 

I can't believe we have to put with this **bleep**.

Developer
dbigham
Posts: 552
Registered: ‎04-01-2009
My Device: Z10, PlayBook

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

[ Edited ]

I have to agree -- I'm kind of disappointed that RIM would release the simulator with such a serious flaw. Perhaps this somehow doesn't affect all computers -- are we a lucky few? I suppose I'll try installing the simulator on another computer tonight to see if it's also broken there.

 

The other thing I don't get is that wasn't this sumulator released in January?  If so, why on earth wouldn't they have released a fix by now?

Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

My simulator does not freeze too often, but I have lots and lots of memory on my machine (8GB).  Those that freeze all the time, how much memory do you have?

Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

John, are you referring to the old simulator now?  The new one should almost never freeze, after you make it past the startup screen. 

 

Also, I'm fairly certain it's CPU usage-related, not memory.  My VM doesn't use very much memory at all.  Did you see the other thread where I compared old and new simulator with my app, with sim-CPU-intensive work and without?  I think it was pretty conclusive, though so far almost no one else has reported their results... 


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

I was referring to the 0.9.2 simulator.  My system thrashed (paging) when I had the 0.9.1 simulator + FB4 running (+all other apps running).  When I doubled my system memory, everything calmed down and I could actually get work done.  I'm assuming the same resources are being taken from VMWare with 0.9.2 as it was with 0.9.1

Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

Adam Stanley of RIM, in the 3rd WebWorks webcast, just said with respect to this particular issue that he "generally tries to set the time to be as close as possible, within a second if you can" (or words to that effect), to avoid this problem.

 

Possibly those who have given up on this will find success if they make it really close... I'm surprised that it would be anywhere near that picky, even if as he says it's related to authentication and the embedded web service that is used for the install.  Seems like 5-10 seconds minimum is a reason difference to allow.  Anyway, for what it's worth...


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
jffurlan
Posts: 1,003
Registered: ‎01-16-2011
My Device: PlayBook (sim)

Re: Error: Username or password is invalid or not specified or time on the device is out of sync

Well, for what it's worth mine worked even if the time was off by an hour or two. Bizarre that this issue seems to be so inconsistent.

- If you like my response/post, or it helped you find an answer you were looking for, please provide a Kudo - white star to the bottom right of this post. -
- Please use the search bar at the top, or check out the PlayBook FAQ's for help getting started -
- Hockey DrillBook -