Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
Hada
Posts: 7
Registered: ‎12-11-2010
My Device: Not Specified

Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

I get this error when I tried to export signed bar file on Flash Builder 4 with SDK 0.9.4.

OS: Win 7 Home 64bit.

 

Does anyone has clue?

 

Message:

"Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version."

 

Thank you,

Naoki

Naoki Hada @hada
Please use plain text.
New Contributor
jacarma
Posts: 5
Registered: ‎03-26-2011
My Device: playbook
My Carrier: none

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

I also have the same problem

 

 

[INFO]       Bar packaging complete
[INFO]       Starting signing tool
manifest error: 
Invalid value '2.0.2' for Package-Version.
[ERROR]     Signing failed

 

[INFO]       Bar packaging complete[INFO]       Starting signing toolmanifest error: Invalid value '2.0.2' for Package-Version.[ERROR]     Signing failed

 

MAC OSX

 

Thanks

Please use plain text.
New Contributor
Hada
Posts: 7
Registered: ‎12-11-2010
My Device: Not Specified

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

jacarma,

 

I followed command line steps from http://www.hsharma.com/tech/tutorials/10-easy-steps-to-package-and-sign-air-apps-for-playbook/.

Only Step 10 part was required, but it did not work.

 

Command line error message shows  "Author is Unknown".

So I specifed "publisher" tag in blackberry-tablet.xml file as same as CSJ file.

Then finaly command line worked.

 

I changed other project setting same way for the blackberry-tablet.xml file.

Then Flash Builder could create singed bar file without command line.

 

Hopefully it helps your case.

 

Thank you,

Naoki

Naoki Hada @hada
Please use plain text.
Developer
berryawesome
Posts: 54
Registered: ‎12-22-2010
My Device: Not Specified

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

[ Edited ]

have you signed it before? If so, you must increase the version number each time you sign a release.

 

 

Please use plain text.
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

@jacarma: im going to assume you are doing a webworks application. make sure that your version value in the config.xml is "2.0.3" - it needs three positions and not two (happened in my case). also try setting a -buildId in the command line when signing/packaging.

 

if that doesnt work copy and paste your config.xml file and what you are typing in the command line. good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Please use plain text.
New Contributor
jacarma
Posts: 5
Registered: ‎03-26-2011
My Device: playbook
My Carrier: none

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

Thank you all.

 

JRab was right. Setting 3 positions in the version field solved the problem.

 

FIXED

Please use plain text.
Regular Contributor
SatishK
Posts: 90
Registered: ‎09-04-2009
My Device: Blackberry Z10
My Carrier: Airtel

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

hello,

 

i have occured same error

 

Error creating BAR file: org.eclipse.core.runtiome: barsigner error:server error: code signing request failed beacause Package-Auther in menifest does not match the common name in developer certifiacte.

 

 

Please use plain text.
BlackBerry Development Advisor
elena_laskavaia
Posts: 417
Registered: ‎10-27-2010
My Device: PlayBook

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

You need to specify -publisher <company name> or add tag <publisher> in blackberry-tablet.xml

Please use plain text.
Regular Contributor
SatishK
Posts: 90
Registered: ‎09-04-2009
My Device: Blackberry Z10
My Carrier: Airtel

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

when i am adding the publisher tag, then application.publisher is an unexpected element/attribute

Please use plain text.
BlackBerry Development Advisor
elena_laskavaia
Posts: 417
Registered: ‎10-27-2010
My Device: PlayBook

Re: Error creating BAR file: org.eclipse.core.runtime.CoreException: manifest error: Invalid value '1.0.0' for Package-Version.

because you did not put it in correct file. read my comment please it has to be in blackberry-talet.xml

Please use plain text.