Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Contributor
jimmyd25
Posts: 43
Registered: ‎11-17-2010
My Device: Not Specified

Error when trying to package the app using Burrito

Hi friends and family!

 

I keep getting an error message when I try to sign and package my app (export release build). On the final step of packaging I get an error and the jist of the message says 'Error: not qnx tag or two many'. I was wondering if anyone else has seen this error or if anyone knows how I can resolve it.

 

Thank you!

 

Please use plain text.
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Error when trying to package the app using Burrito

what does your -app.xml file and your blackberry-tablet.xml file look like?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Please use plain text.
Contributor
jimmyd25
Posts: 43
Registered: ‎11-17-2010
My Device: Not Specified

Re: Error when trying to package the app using Burrito

Hey JRab!

 

my -app.xml looks like this:

 

<?xml version="1.0" encoding="utf-8" standalone="no"?>
 <id>com.clearbridgemobile.tablet.basecamp</id>
 <filename>BasecampPlaybook</filename>
 <name>Nomad</name>
 <versionNumber>0.0.1</versionNumber>
 <copyright>Clearbridge Mobile Inc.</copyright>
 <initialWindow>
 <systemChrome>none</systemChrome>
 <transparent>false</transparent>
 <content>BasecampPlaybook.swf</content>
 <!--<visible>true</visible>-->
 </initialWindow>
 <icon>
 <image72x72>assets/icons/icon_72x72.png</image72x72>
 </icon>
</application>
and my blackberry-tablet.xml looks like this:

<qnx>

 <initialWindow>

 <systemChrome>none</systemChrome>

 <transparent>false</transparent>

</initialWindow>

<publisher>Clearbridge Mobile Inc.</publisher>

<category>core.media</category>

    <icon>

        <image>NomadIcon.png</image>

    </icon>

    <splashscreen></splashscreen>

</qnx>

 

Could anything here be causing the problem?

 

 

Please use plain text.
Developer
jffurlan
Posts: 1,003
Registered: ‎01-16-2011
My Device: PlayBook (sim)
My Carrier: Rogers

Re: Error when trying to package the app using Burrito

[ Edited ]

Not sure if this relates to your problem, and I know that the Blackberry-Tablet.xml overwrites the -app.xml, but it appears that you have your icon defined twice (unless i'm reading it wrong).

In your -app.xml you have:

 

 <icon>
      <image72x72>assets/icons/icon_72x72.png</image72x72>
 </icon>

 And in your blackberry-tablet.xml you have:

 

<icon>
      <image>NomadIcon.png</image>
</icon>

 

Other than that everything looks normal...

 

 

- If you like my response/post, or it helped you find an answer you were looking for, please provide a Kudo - white star to the bottom right of this post. -
- Please use the search bar at the top, or check out the PlayBook FAQ's for help getting started -
- Hockey DrillBook -
Please use plain text.
Contributor
jimmyd25
Posts: 43
Registered: ‎11-17-2010
My Device: Not Specified

Re: Error when trying to package the app using Burrito

I tried changing that and it didn't help. Thanks for the suggestion though.

Hopefully I find what is causing the error soon. 

Please use plain text.