Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
peter9477
Posts: 6,448
Registered: ‎12-08-2010
My Carrier: none

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

d_source, it sounds like you're describing something covered by this post, in terms of how the package id is defined: http://devblog.blackberry.com/2012/03/package-id-rejected-by-app-world/

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
Developer
d_source
Posts: 116
Registered: ‎03-08-2011

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

Yuppers. I was trying to submit a package with a different name and therefore that's why I got the message. Didn't see that info in here so I thought i'd post it. Thx for the link.

Please use plain text.
Developer
monkeypunch
Posts: 36
Registered: ‎01-13-2012
My Carrier: ATT

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

[ Edited ]

I've got this error now, I've tried all the suggestions on here. There have got to be better error messages!

 

Someone says it's because files signed with different keys, someone else says the version number is not incremented, someone else says it's because the file name is different. What is going on? 

 

So far, I've created a new app and uploaded it. After a few weeks I heard back via email that the app is denied because the file is not signed. I opened up the file and saw that there were no manifest.mf file. Why didn't the server mention this when I uploaded it? Anyway, I've signed it for sure this time and now when I upload it I'm getting this error.

 

So right now I just want to know what is being compared to what? I mean where is the packageId that it's looking for and what should this match?

 

I opened the Manifest file and here's what I've got:

 

Archive-Manifest-Version: 1.1
Archive-Created-By: BlackBerry Tablet OS Air BAR Packager 1.4.2

Package-Type: application
Package-Author: My Name
Package-Name: MyAppName
Package-Version: 1.0.0.12
Package-Architecture: armle-v7
Package-Author-Certificate-Hash: ...
Package-Author-Id: gYAA...
Package-Id: gYAB...
Package-Version-Id: gYAC...

Application-Name: MyAppName
Application-Description: MyAppName
Application-Version: 1.0.0.12
Application-Category: core.media
Application-Requires-System: Tablet OS/1.0.8.0
Application-Development-Mode: false
Application-Id: gYAD...
Application-Version-Id: gYAE...

 

File name is MyAppName.bar. The product name in the vendor portal is "My App Name" it has spaces.

 

QNX bar file:

 

<qnx>
   <initialWindow>
      <systemChrome>none</systemChrome>
      <transparent>false</transparent>
   </initialWindow>

   <author>My Company Name</author>
   <category>core.media</category>
   <icon>
      <image>assets/images/app-icon-86.png</image>
   </icon>
   <buildId>12</buildId>
</qnx>

 

Please use plain text.
Developer
peter9477
Posts: 6,448
Registered: ‎12-08-2010
My Carrier: none

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

monkeypunch, it's unclear whether you've read the article I linked to a few posts back, as it should tell you what to do in this case.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
Developer
monkeypunch
Posts: 36
Registered: ‎01-13-2012
My Carrier: ATT

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

Peter,

 

I did miss it some how. Thanks for that.

Please use plain text.
Contributor
filipoff
Posts: 30
Registered: ‎02-12-2011

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

I wasted another evening on that  process!!!!@#$#$ :/

It should be done on server site (RIM site) !!!
To sign this app what ever need network connection.
Simple form wiht 3 params: swf,xml,icon,
Only perpuse off this proces is to put app to device wiht RIM blessing so why can I get it directly!!!

WP7 process is way  better.

Please use plain text.
Trusted Contributor
wmatt
Posts: 107
Registered: ‎10-02-2011
My Carrier: none

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

[ Edited ]

I'm getting the Package ID error now when submitting an update to my AIR app. The Package ID's are different, I checked against the last version. Something seems to have happened when I installed the Webworks SDK that I'm using for a different app. I think I have the keys backed up, but restoring them didn't help. Probably my error somewhere. Frustrating. 

 

Anything else I can try? I don't want to scrap my current app and users.

 

Update: I contacted vendor support as other forum posts indicate they might be able to help. Waiting to hear back.

Please use plain text.