Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
RapsFan
Posts: 442
Registered: ‎08-02-2010
My Device: Z10

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

Ahhh wish I had known that, good to know now though. Thanks.
Regular Contributor
ryan_robinson
Posts: 60
Registered: ‎03-07-2011
My Device: Z10 + PlayBook

Re: File bundle has been rejected. Package ID is required for all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

The "version" attribute in the "widget" tag In the config xml file? I just tried that and I'm still receiving the same error.

Developer
RapsFan
Posts: 442
Registered: ‎08-02-2010
My Device: Z10

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

Build version is different. I never used it before though.
Developer
shahumang8
Posts: 671
Registered: ‎08-09-2010
My Device: Not Specified

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

[ Edited ]

Hello,

 

   Any one got any solution for this.

 

Thanks.

Developer
RapsFan
Posts: 442
Registered: ‎08-02-2010
My Device: Z10

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

I was told it was because I used a different set of keys to sign. I had to release my update as a whole new app.
Developer
gyubok
Posts: 520
Registered: ‎10-08-2009
My Device: Bold 9900

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

Can someone from RIM please take care of this matter? I can't resubmit for failed bundle!

Developer
RapsFan
Posts: 442
Registered: ‎08-02-2010
My Device: Z10

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

Agreed. I have pee'd off customers
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

oh boy -- didn't realize a new set of keys meant we needed to release our apps as new apps -- what happens to those who need to refresh their keys (i think i read they have an expiration date?) -- i had to use new keys -- wonder how this will affect my older apps.

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

JRab, that's already been covered in http://supportforums.blackberry.com/t5/Tablet-OS-SDK-for-Adobe-AIR/What-happens-when-the-signing-cer...

 

You've been away... a bit less than a year ago, as you may recall, there was a slew of newbies facing similar problems because they kept screwing up their signing keys and requesting new ones, then dealing with users losing their app data and getting duplicate icons when an app was updated.  Presumably they've now basically prevented that from happening in quite the same way by disallowing submissions when the keys are different. 

 

Makes sense: better to catch the problem before it gets to the user.  Of course, if you've really lost your original keys then you're still toast, but at least this way it's more in your face about it so you're forced to deal with the issue before it gets to the user.


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: File bundle has been rejected. Package ID is requiredfor all .bar file. If this is an upgrade Package ID must match the original Package ID in original file bundle

well would you look at that -- learned something new -- thanks peter -- now i have to somehow organize and rethink my older app signatures -- good thing nothing posted was for money -- that would have been a nightmare. 

 

:Oops:

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman