Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
Posts: 7
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: o2

Flash Builder 4.7 - Won't install app

I'm having some trouble deploying an app using flash builder 4.7. I have tried the sample project that comes with the 2.1 sdk and tried creating my own following the online example.

 

When trying to deploy to a physical playbook I get no error, it simply compiles and appears to be "launching" something then quickly stops. The app also does not appear in the apps section.

 

When deploying to the simulator I get this message:

Deployment Failed: Info: Sending request: Launch
Info: Action: Launch
Info: Launching HelloWorld.debug.testDev_World_debug809da4e5...
Info: done

I beleive my certificates/tokens are all correct as I had issues with them at first which i resolved. The only issue I can think of is that in my xxxx-app.xml I have to use the line:

<application xmlns="http://ns.adobe.com/air/application/3.6">

I can't figure out a way to install air 3.1 in flash builder 4.7 to check if that is the issue.

If anyone has any ideas to what the issue might be or needs more information to help please reply!!

New Contributor
Posts: 7
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: o2

Re: Flash Builder 4.7 - Won't install app

Quick update I was able to change the air version to 3.1 using the  useFlashSDK argument to false in the actionscript properties.

Also the app does install it was just off screen but it wont launch even manually.

New Contributor
Posts: 7
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: o2

Re: Flash Builder 4.7 - Won't install app

Bump

 

A bit more information I tried to isntall using the tablet OS graphical aid and received this output when trying to upload the .bar file thats generated during flash builders compiling:

 

Info: Sending request: Install and Launch
Info: Action: Install and Launch
Info: File size: 6027226
Info: Installing HelloWorld.debug.testDev_World_debug809da4e5...
Info: Processing 6027226 bytes
Info: Progress 3%...
Info: Progress 100%...
actual_dname::HelloWorld.debug.testDev_World_debug809da4e5
actual_id::testDev_World_debug809da4e5
actual_version::1.0.0.1
result::success
Info: Launching HelloWorld.debug.testDev_World_debug809da4e5...
Error: Failed to create application process: Exec format error

New Contributor
Posts: 7
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: o2

Re: Flash Builder 4.7 - Won't install app

command line result after compiling the bar file with flash builder:

 


C:\Programming\ninjaornun\trunk\BlackberryTest\bin-debug>cmd.exe
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Programming\ninjaornun\trunk\BlackberryTest\bin-debug>blackberry-deploy -inst
allApp -launchApp -package BlackberryTest.bar -device 169.254.0.1 -password fall
on22
Info: Sending request: Install and Launch
Info: Action: Install and Launch
Info: File size: 7641291
Info: Installing BlackberryTest.debug.testDev_yTest_debug945873ee...
Info: Processing 7641291 bytes
Info: Progress 3%...
Info: Progress 100%...
actual_dname::BlackberryTest.debug.testDev_yTest_debug945873ee
actual_id::testDev_yTest_debug945873ee
actual_version::0.0.0.1
result::success
Info: Launching BlackberryTest.debug.testDev_yTest_debug945873ee...
result::15528094
Info: done

C:\Programming\ninjaornun\trunk\BlackberryTest\bin-debug>

App instantly closes as usual on trying to launch

New Contributor
Posts: 7
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: o2

Re: Flash Builder 4.7 - Won't install app

Interesting turn of events, exporting a "build release" installs and launches fine. Not ideal but progress, could it be token/cert issues then?

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: Flash Builder 4.7 - Won't install app

Are you using any API's that AIR 3.1 does not support like Stage3D for example?

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
New Contributor
Posts: 7
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: o2

Re: Flash Builder 4.7 - Won't install app

Hi,

 

Thanks for the reply I was starting to think no one could help :smileyhappy:

 

I thought the game itself might be a problem so I did 2 seperate projects using the sample project from the sdk download and also a project following the online blackberry SDK documentation for "your first air app". These suffered from the same problem when trying to build to a playbook device or the simulator directly from flash builder 4.7 using "run" or "debug". 

However if I do a release build "project>export release build" and isntall this via command line the app runs fine.The only reason I can think of is that this may be because the "release build" version doesn't rely on a debug token when installed on the device? Is it possible that this may be the issue and do you have any recommended steps to identify if it is an issue with the debug tokens?

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: Flash Builder 4.7 - Won't install app

Hmm.. it may be a problem with the debug token. On your physical device when you go to "Security -> Development mode"  does it display that a debug token is installed and valid? 

 

Also based of the documentation try deleting your adt.jar file. Instuctions here - https://developer.blackberry.com/air/documentation/playbook/ww_air_getting_started/install_bbtos_sdk...

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
New Contributor
Posts: 7
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: o2

Re: Flash Builder 4.7 - Won't install app

I can confirm the debug token is on the device and displays valid and matches the author name set in my application. Also the adt.jar didn't exist when I downloaded the sdk 2.1.0 so I've not had to delete it.