Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Contributor
andrewk
Posts: 33
Registered: ‎02-24-2011
My Device: Not Specified

Flash Builder won't connect to the PlayBook simulator

I've spent quite a few hours trying to get a PlayBook development environment set up, including some time with an experienced developer. So far I've installed everything, but Flash Builder absolutely refuses to connect to the PlayBook simulator.

 

I'm using Flash Builder 4 (not Burrito), and the 0.9.3 versions of the simulator and the SDK.

 

I can ping the PlayBook, so I know the IP address is correct. It's in development mode, and I've fixed the date/time to match my host machine.

 

However, when I try to deploy my app and debug it, Flash Builder gives me this error: "Cannot connect: Connection to https://195.168.1.72 refused. You may have to reboot the target."

 

Things I've tried:

- Rebooting the PlayBook, countless times.

- Recreating the PlayBook VM.

- Changing my VMWare network adapter to bridged mode.

 

I'm completely out of ideas at this point, and so is the guy helping me. Is there any way for me to get more information about what's going on? Is there anything else to try, besides reinstalling everything again?

 

Thanks!

Please use plain text.
Developer
biggerCC
Posts: 270
Registered: ‎12-13-2010
My Device: PlayBook 16GB, BB10 Dev Alpha

Re: Flash Builder won't connect to the PlayBook simulator

Do you have any software firewall or "internet security suite" installed?

Some of these "masterpieces" won't allow communication on the uncommon ports...

- - -
My approved apps @ App World
Please use plain text.
Developer
biggerCC
Posts: 270
Registered: ‎12-13-2010
My Device: PlayBook 16GB, BB10 Dev Alpha

Re: Flash Builder won't connect to the PlayBook simulator

If that did not help, I strongly recommend to have a look at the transitted data packets with Wireshark (http://www.wireshark.org/) or similar tools.

- - -
My approved apps @ App World
Please use plain text.
Contributor
andrewk
Posts: 33
Registered: ‎02-24-2011
My Device: Not Specified

Re: Flash Builder won't connect to the PlayBook simulator

Sorry, I forgot to mention that I had allowed VMWare, Flash Builder, and Eclipse in the Windows Firewall. I also tried completely shutting down the firewall, no difference.

 

I will try Wireshark though, thanks for the suggestion.

Please use plain text.
New Contributor
xavings
Posts: 8
Registered: ‎02-24-2011
My Device: Playbook Simulator

Re: Flash Builder won't connect to the PlayBook simulator

Same problem.

I'm  running in a Mac with WMware Fusion 3.2.1 and it tells me the same when I try to install it from the command line.

 

Any idea?

Please use plain text.
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Flash Builder won't connect to the PlayBook simulator

can you guys ping the IP of your simulator?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Please use plain text.
New Contributor
xavings
Posts: 8
Registered: ‎02-24-2011
My Device: Playbook Simulator

Re: Flash Builder won't connect to the PlayBook simulator

The simulator IP is 192.168.171.128

 

and the commands responds:

 

Error: Cannot connect: Connection to https://172.168.171.128 refused. You may have to reboot the target.

Please use plain text.
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Flash Builder won't connect to the PlayBook simulator

u posted two different sim IPs. which one are u using to connect via flash builder?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Please use plain text.
New Contributor
xavings
Posts: 8
Registered: ‎02-24-2011
My Device: Playbook Simulator

Re: Flash Builder won't connect to the PlayBook simulator

[ Edited ]

OK,

 

My playbook IP is 192.168.171.128

 

So, the command I use to install the .bat is this:

 

.../sdks/blackberry-tablet-sdk-0.9.3/bin/blackberry-deploy -installApp -device 172.168.171.128 -package PlayBookTest.bar -password 1234

and it responds this:
Error: Cannot connect: Connection to https://172.168.171.128 refused. You may have to reboot the target.

It seems that is trying to connect to a diferent IP...

 

Please use plain text.
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Flash Builder won't connect to the PlayBook simulator

it is connecting to a different IP because u are putting in a different IP. your command line has 172 but your actual sim IP is 192. So change 172.168.171.128 to 192.168.171.128 in your command line and see what happens. good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Please use plain text.