Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Contributor
Posts: 40
Registered: ‎07-31-2011
My Device: Playbook
My Carrier: n/a

Flash CS5 Development for BB Playbook

In need of some assistance. I have an app I created with Flash CS5 (attempted to set as Flash Player 10 and AIR 2.5, neither of which worked for me). I was able to compile the application and use the command prompts to get it loaded onto the VMWare Playbook simulator. It loads everything on the device, but I cannot get the application to launch in the simulator.

I have a custom xml (not the flash compiled one), with the appropriate tags. SWF and icons compiled into a .bar file. When testing the swf outside of the simulator, the game functions perfect. I just cant seem to get it to actually launch on the simulator. All I see, is the general BB icon on the main simulator screen, then when it attempts to launch, I see a brief screen with the blackberry icon, which closes a few short seconds after. Not sure what went wrong.

 

If any one can lend some assistance that would be awesome!! I've been googling and trying several different things all day to no avail. Thanks in advance!!

 

(sidenote: I didnt create the p12 & signing cert because it didnt seem necessary if I was only testing the app on a simulator. If it packaged and loaded onto the playbook simulator, it didnt seem necessary for it to launch. I could be wrong.) 

Contributor
Posts: 40
Registered: ‎07-31-2011
My Device: Playbook
My Carrier: n/a

Re: Flash CS5 Development for BB Playbook

I have also just attempted to use a signed app to launch in the simulator (as seen with the steps here http://ptm.fi/?p=317 ) with the same results, unfortunately. Any assistance is appreciated.

 

Another side note, I noticed my icons do not show up on the simulator even though they are packaged with the application. The app is also listed under ALL on the VMWare simulator opposed to under the GAMES tab as it should be since I tagged it to be as such in the XML file.

New Contributor
Posts: 5
Registered: ‎03-31-2011
My Device: PowerBook
My Carrier: d

Re: Flash CS5 Development for BB Playbook

I'm not sure if this matters anymore with the new simulator, but when I made an app in flash builder, the bar's manifest file would have the development mode tag toggled true. You might need to set it to true...not sure if manually doing this will help though

Contributor
Posts: 40
Registered: ‎07-31-2011
My Device: Playbook
My Carrier: n/a

Re: Flash CS5 Development for BB Playbook

Hey, thanks for the response. I'm not quite sure which format the <development> tag needs to be in. If you could post that, that would be awesome! I tried <development>true</development> but apparently, it didnt like that. Thx!!

 

I also just noticed that when I tried to attach my icons in the XML (as seen in the sdk manifest samples), and then package, load and launch via command prompt, it was stating the icons werent included in the bar file. I'm thinking this could be the same for my swf file - which would explain why it wouldnt launch because there's nothing included in the pacakge to launch. Downloading a trial version of Flash Builder 4.5 right now to test it out.

Contributor
Posts: 40
Registered: ‎07-31-2011
My Device: Playbook
My Carrier: n/a

Re: Flash CS5 Development for BB Playbook

Thanks for the help!!! I just had an epiphany and figured it out. I was trying to package the bar file while icons, sdk packager, and swf were rooted into different menus instead of having all pertinent files located where the bin sdk packager is located. Thought it didnt matter, but apparently it does!! App is loaded and functional. Time to conquer to world :smileyhappy: