Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
mikehopkins
Posts: 2
Registered: ‎02-10-2011
My Device: Not Specified

Flash professional quirk

I'm trying to develop an app using Flash Prossional (since I don't have time to convert everything over to Flex), I compile a BAR using the blackberry-airpackager command line and I'm having a weird issue getting the app to run.

 

I'm using Flash Builder 4.0.1 and Flash Professional CS5. Both use the same blackberry 0.9.3 and AIR 2.5 SDKs that I've downloaded today.

 

When I use Flash Builder, the app compiles and runs fine. But when using the same SDKs (blackberry 0.9.3, and AIR 2.5) the launcher freezes(?) and never finishes launching the app.

 

I have even tried making a blank SWF with guide boxes in the corners to see if it was my AS that was acting up, but I get the same thing. Compiled SWF

Unfortunately, this is what I'm getting...


screenshot_47.jpg

My AS3 Linkages should be set properly too.


AS3 Linkages

Here's the XML that FP built and compaired it to the one that FB makes. Nothing jumps out at me...

 

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<application xmlns="http://ns.adobe.com/air/application/2.5">
	<id>com.mmikehopkins.playbookTest</id>
	<versionNumber>1.0.1</versionNumber>
	<filename>playbookTest</filename>
	<name>Testing the Playbook</name>
	<description></description>
	<copyright>Mike Hopkins 2011</copyright>
	<initialWindow>
		<content>playbookTest.swf</content>
	<maximizable>false</maximizable><minimizable>false</minimizable><resizable>false</resizable><visible>true</visible><systemChrome>standard</systemChrome><transparent>false</transparent></initialWindow>
	<icon>
	</icon>
<customUpdateUI>false</customUpdateUI></application>

 

 

Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: Flash professional quirk

Your images have to be approved by the moderator, but in the mean time, does the app launch as a standard AIR application on your desktop?  Trying to determine if it is a configuration issue or a crashing bug issue.

New Contributor
mikehopkins
Posts: 2
Registered: ‎02-10-2011
My Device: Not Specified

Re: Flash professional quirk

I have published the same SWF for both Desktop AIR and AIR for Android. Both seem to work fine on my OSX machine and Nexus One respectively.

 

I'm thinking if I do not get the issue fixed in the next day or so (as I seem to be the only one experiencing it) I'm going to wipe all traces of Flash, VMWare and the SDKs and try starting over from scratch...

Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: Flash professional quirk

That image (the actual screenshot with the gray rectangle on the right) actually looks like there's no app running.  If you bottom-swipe (that's swiping *up* from the bottom bezel) or click the arrow on the right edge of the category bar, it will move the bar down and show you whether there's really an app running.

 

The grey stuff looks to me like a glitch that I think is basically a simulator bug... I get it sometimes when my app crashes (through no fault of its own).

 

So I think your app might simply have crashed, again not necessarily from its own problems.


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!