Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
verbruggher
Posts: 4
Registered: ‎04-04-2011
My Device: Playbook
My Carrier: N

FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

I have Adobe Flash Builder 4.5.1, and when searching for new software updates, it finds a new version of BlackBerry Tablet OS Plugin 1.1.0.201106171124.

 

When I start the update of this plugin I get an error:

 

"An error occurred while collecting items to be installedsession context was:smileysad:profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).No repository found containing: osgi.bundle,org.eclipse.wst.server.core,1.1.206.v20110110"

 

Does anyone here know how I can resolve this?

 

 

Please use plain text.
New Contributor
verbruggher
Posts: 4
Registered: ‎04-04-2011
My Device: Playbook
My Carrier: N
Please use plain text.
Developer
CoCopia
Posts: 231
Registered: ‎05-03-2011
My Device: PlayBook V1 and proud of it :-)
My Carrier: Legs

Re: FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

Yes dont update from within Eclipse, go here and click the link for the SDK for your platform, and do a manual install.

Keep the Forum productive and useful for all. Click Kudos button if I've helped you. Select Solved to help everyone.

PlayBook qualifying app - Pandoras' Lights
Blog - CoCopia.co.uk Catch me on Twitter cocopia_apps
Please use plain text.
BlackBerry Development Advisor
jdolce
Posts: 172
Registered: ‎10-25-2010
My Device: Not Specified

Re: FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

When using Flash Builder 4.5.1 you need to use the Eclipse update site in order to update your plugin. Using the installer will not actually update the plugin.

 

I have reported the issue internally and will follow up when we hear more. Might need more information on your setup.

Please use plain text.
Developer
CoCopia
Posts: 231
Registered: ‎05-03-2011
My Device: PlayBook V1 and proud of it :-)
My Carrier: Legs

Re: FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

This might be a platform issue then, as on my Mac, this works better than the repositories.

Keep the Forum productive and useful for all. Click Kudos button if I've helped you. Select Solved to help everyone.

PlayBook qualifying app - Pandoras' Lights
Blog - CoCopia.co.uk Catch me on Twitter cocopia_apps
Please use plain text.
New Contributor
verbruggher
Posts: 4
Registered: ‎04-04-2011
My Device: Playbook
My Carrier: N

Re: FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

Thats what I did, but even after installing that, it still finds a newer version

https://picasaweb.google.com/lh/photo/HKjPWrPiM9CQcmGSMTAA8vyYQGidW1JFEVQc9MMmCHA?feat=directlink%EF...

Please use plain text.
New Contributor
verbruggher
Posts: 4
Registered: ‎04-04-2011
My Device: Playbook
My Carrier: N

Re: FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

Which Eclipse update site should I use with Flash Builder 4.5.1?
Please use plain text.
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

[ Edited ]

Hey verbruggher,

Not sure if you ever solved your problem -- but today I ran into the same one when reviving my windows system and installing Flash Builder / BlackBerry Tablet OS SDK. Here's what I did to solve it:

First the update site is what the docs @ http://docs.blackberry.com/en/developers/deliverables/30122/Install_the_BBTOS_SDK_in_FB_env_1702686_...

 

http://docs.blackberry.com/en/developers/deliverables/30122/Install_the_BBTOS_SDK_in_FB_env_1702686_...

 

Second my problem ended up being the config.ini file located in C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\configuration -- As per the instructions I opened up the file and proceeded to put in the # where it belonged right before the osgi.configuration.area=@user.home/Adobe Flash Builder 4.5/cascaded/308971/configuration -- and I assumed everything was done alright and proceeded to update Flash Builder 4.5 but then ran into that nasty error:

An error occurred while collecting items to be installed.


Everything looked fine and even restarted Flash Builder a few times and the same error kept popping up. So then I remembered that when I opened the config.ini file in NotePad it opened it weird -- all the lines in the file were on the same single line -- did not appear to have any line breaks.

 

#This configuration file was written by:  ... pse.p2.profile=epp.package ... er.home/Adobe Flash Builder 4.5 ... 6x_v20100806.jarequino ... 8-0911osgi.bundles=reference\:file\:org.eclipse.equ ... r_1.0.200.v20100503.jar@1 ... nox.simpleconfigur ... se.equinox.simpleconfigurator/bund ... lexbuilder.stan ... k.extensions=osgi.bundles.defaul ... er.standalone.FlashBuilderApplicationeclipse.p ... ion.area=@user.ho ... /cascaded/308971/configurati ... ion.area=file\: ... ation.cascaded=true

 

So I first opened the config.ini file in WordPad then i went to File > Save (no changes were made but still saved) -- this puts in all of the needed line breaks. Then I opened the file in NotePad and to my surprise this is what the file looked like:

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Fri Jul 30 17:13:05 PDT 2010
org.eclipse.update.reconcile=false
eclipse.p2.profile=epp.package.java
osgi.instance.area.default=@user.home/Adobe Flash Builder 4.5
osgi.framework=file\:plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
equinox.use.ds=true
eclipse.buildId=I20100608-0911
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.200.v20100503.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.product=com.adobe.flexbuilder.standalone.producte36
osgi.framework.extensions=
osgi.bundles.defaultStartLevel=4
eclipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication
eclipse.p2.data.area=file\:p2/# osgi.configuration.area=@user.home/Adobe Flash Builder 4.5/cascaded/308971/configuration
osgi.shared.configuration.area=file\:configuration
osgi.configuration.cascaded=true

 

Notice the number sign is after the line eclipse.p2.data.area=file\: p2/ and not before the correct spot on the next line. So after changing that mistake and having the file look like this:


#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Fri Jul 30 17:13:05 PDT 2010
org.eclipse.update.reconcile=false
eclipse.p2.profile=epp.package.java
osgi.instance.area.default=@user.home/Adobe Flash Builder 4.5
osgi.framework=file\:plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
equinox.use.ds=true
eclipse.buildId=I20100608-0911
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.200.v20100503.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.product=com.adobe.flexbuilder.standalone.producte36
osgi.framework.extensions=
osgi.bundles.defaultStartLevel=4
eclipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication
eclipse.p2.data.area=file\:p2/
#osgi.configuration.area=@user.home/Adobe Flash Builder 4.5/cascaded/308971/configuration
osgi.shared.configuration.area=file\:configuration
osgi.configuration.cascaded=true

 

After doing that -- the error disappeared and the application finally updated without a problem. So to summarize check the config.ini file and make sure all the line breaks are present and the number sign is where it belongs. Hopefully this shed some light on the situation. Good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Please use plain text.
Developer
Smugrik
Posts: 185
Registered: ‎04-05-2011
My Device: PlayBook
My Carrier: Bouygues Telecom

Re: FlashBuilder 4.5.1 cannot perform BlackBerry Tablet OS Plugin update

I had the same kind of problem, this is more likely to be an Eclipse-related issue,

on the second srceen, try unchecking the "contact all update sites during install to find required software",

This was enough for me to have the plugin downloaded and installed.

Julien
Web: smugrik.org Follow: @Smugrik
PlayBook apps:
OSCream
kiPass
Please use plain text.