Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Regular Contributor
bigmokujin
Posts: 67
Registered: ‎03-25-2011
My Device: PlayBook
My Carrier: wifi
Accepted Solution

Has anyone gotten FB 4.7 to work for BB10 projects?

I have spent some time migrating to a new development environment.  One of the updates to that environment was the use of FB4.7  I have followed the install instructions as documented here on the forums.  I am trying to launch a very simple actionscript mobile project and haven't had any success.

 

I am attempting to debug an app on the dev alpha device.  Unfortunately, when the app launches all I get is a black screen that shows up, then immediately disappears.  I do not get any error message logged within the FB Debug console, and there seems to be no error output.  I did notice that when the black screen disappears the FB4.7 debug process is still trying to complete.  And after reaching 100% I get an error message stating that it could not find the device to debug against.  Which seems erroneous to me.

 

Any advice or assistance would be appreciated.

 

Please advise.

 

Brandon Phillips

Please use plain text.
Developer
ChernyshovYuriy
Posts: 116
Registered: ‎11-18-2010
My Device: BlackBerry PlayBook
My Carrier: null

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

Hi, take a look at my replays here
http://supportforums.blackberry.com/t5/Adobe-AIR-Development/Can-I-use-Flash-Builder-4-7-to-develop-...
I have same behavior with PlayBook OS 2.1 and Flash Builder 4.7, but none of the authorities response.
Please use plain text.
Regular Contributor
bigmokujin
Posts: 67
Registered: ‎03-25-2011
My Device: PlayBook
My Carrier: wifi

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

Thanks Cherny...

 

You are right they seem to be the same problem.  So I will watch your thread rather closely, even though it shows as being solved.

 

One question, are you attempting to use the default AIR3.4 that is installed with FB4.7 to build apps for the playbook or BB10?

 

As I understood it, AIR3.1 was the highest level currently supported.  With that in mind I attempted to configure my FB4.7 install to work with AIR3.1.  I used the following instructions to do so:

 

http://helpx.adobe.com/flash-builder/kb/overlay-air-sdk-flash-builder.html

 

My initial attempt just overlayed the backdated AIR SDK into the AIRSDK directory.  Which allowed for FB4.7 to see the current BB10 project, but produced an error that the AIR3.1 SDK did not have AIR.  When I actually deleted everything in the AIRSDK directory and overlayed the AIR3.1 SDK, FB4.7 reported an error in the 'package explorer' pane.  So something is definitely not right.

 

I would really like to hear from someone that has FB4.7 configured with the BB10AIRSDK and is able to deploy to a physical device.  Cause at this point it does not seem possible.  I tweeted an Adobe contact to try and get an answer concerning the package explorer errors, but I am still waiting to hear back from that front.

 

Hopefully, someone here could offer some additional input.  We shall see.  At this point, I may need to simply find and install FB4.6 as I am confident that works.

 

Please advise.

 

Brandon

Please use plain text.
Developer
ChernyshovYuriy
Posts: 116
Registered: ‎11-18-2010
My Device: BlackBerry PlayBook
My Carrier: null

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

Hi Brandon. Thanks to consider my replay. Just today I have received Blackberry 10 alpha device from RIM and have to say that with Builder 4.6 and AIR SDK 3.1 it works fine. With default Builder 4.7 settings it doesn't work both on Playbook and BB10 Dev Alpha devices. I have read your article about configuring AIR SDK and my opinion that it is a problem but I have no time now to test it. Thanks anyway.
Yuriy.
Please use plain text.
Developer
ChernyshovYuriy
Posts: 116
Registered: ‎11-18-2010
My Device: BlackBerry PlayBook
My Carrier: null

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

[ Edited ]

Ok, I have try a link
http://helpx.adobe.com/flash-builder/kb/overlay-air-sdk-flash-builder.html
but meet same error as You.
Up to now I have to use FlashBuilder 4.6 with AIR SDK 3.1 and OS SDK 3.0 for the Plackberry 10 Alpha device and for the Playbook device: FlashBuilder 4.6 AIR 3.1 and SDK 2.0.

Please use plain text.
Developer
apman
Posts: 193
Registered: ‎11-12-2010
My Device: Not Specified

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

I got the FB 4.7 environment to work with BB10 and my DevAlpha, so it's possible. And I didn't have to do any overlaying of SDK's. Have you seen the instructions here:


https://developer.blackberry.com/air/documentation/bb10/install_bbtos_sdk_fb47.html

Specifically the step "Force AIR runtime to version 3.1", which is easy to miss, because it's within the "Create your first App" section (I skipped it initially, thinking I knew how to do that part ... :-), and I think I ended up with similar problems as yours then).

https://developer.blackberry.com/air/documentation/bb10/gsg_change_runtime_fb.html#mah1354223642439

 

Hope that helps

Anna

 


My app : Get set - Get up!   Get ready for the snooze revolution.

Please use plain text.
Developer
ChernyshovYuriy
Posts: 116
Registered: ‎11-18-2010
My Device: BlackBerry PlayBook
My Carrier: null

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

[ Edited ]

Yes, speaking about Playbook device, with these options meansioned above using FB 4.7 and SDK 2.0 works well, switching to SDK 2.1 causes same error. Speaking about Alpha 10 device - yes, these options solve a problem -  thanks a lot Anna !

Please use plain text.
Regular Contributor
bigmokujin
Posts: 67
Registered: ‎03-25-2011
My Device: PlayBook
My Carrier: wifi

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

Anna,

 

Thank you so much for the input.  I had looked at the instructions once before, and apparently dismmissed them when looking at another similiar thread here in the forum.  After reverting back to the original AIR3.4 sdk and following the instructions you provided I was able to successfully deploy to the devAlpha device.

 

I am still curious if this fix will apply to the playbook2.1 device.  As that will be the next place to deploy my app.  But I will continue to monitor the forums for that solution as well.

 

Thanks again.

 

Brandon

 

 

Please use plain text.
Developer
apman
Posts: 193
Registered: ‎11-12-2010
My Device: Not Specified

Re: Has anyone gotten FB 4.7 to work for BB10 projects?

[ Edited ]

Glad it was useful, bigmokujin!

 

Setting up another workspace for PlayBook dev in FB 4.7 will be next for me too - but I need to finish the BB10 version of my app out first ...

 

I think this thread has good info in it - look for dmalik's posts!

http://supportforums.blackberry.com/t5/Adobe-AIR-Development/Can-I-use-Flash-Builder-4-7-to-develop-...

 


My app : Get set - Get up!   Get ready for the snooze revolution.

Please use plain text.