Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Regular Contributor
L7ColWinters
Posts: 82
Registered: ‎11-12-2010
My Carrier: Verizion
Accepted Solution

Images disappear after loading another view with webview

ok so initially I had an old bar that was signed and I put that on the playbook to see what functionality it had. That bar worked exactly how it was supposed to. I had the source and I had to change something but first I needed to update the sdk because I don't have the old sdk that it was built with, built for when air 2.5 was out. All I did was set 3.1 as the air version and update the blackberry tablet sdk includes. It compiled and loaded on the playbook perfectly fine, but after I click on an image that acts as a button, that goes to a view with a webview in it, and return back to the initial view, all the images on the initial view are gone and I can't click on any of them.

 

It's weird I remember this happening a long time ago and it has to do with something about the change in SDK/AIR but I just don't remember what is causing this... If anyone knows what could cause the webview to make images disappear on a reload of ANOTHER view, let me know. btw, the webview was destroyed on the previous view.

Please use plain text.
Regular Contributor
L7ColWinters
Posts: 82
Registered: ‎11-12-2010
My Carrier: Verizion

Re: Images disappear after loading another view with webview

It was a problem with the webview implementation i guess, very unstable object...

Please use plain text.