Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Posts: 137
Registered: ‎10-26-2010
My Device: Bold 9900 + PlayBook
My Carrier: Rogers

New SDK Available

http://us.blackberry.com/developers/tablet/

 

There are new downloads for the SDK, version beta two is now available. There's also official support for Linux now. I'm not certain if there's also a simulator update, I'm in the process of downloading both of them.

 

The API reference doesn't seem to have changed, and there's no mention of the UI guidelines yet.

--------
Taylor Byrnes
Developer
Posts: 889
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: New SDK Available

I think the simulator is still the same.


Read my thoughts on BlackBerry Development at news.ebscer.com
Developer
Posts: 43
Registered: ‎11-19-2010
My Device: Blackberry Tour
My Carrier: Verizon

Re: New SDK Available

Yay Smiley Very Happy

Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: New SDK Available

Recompile one of my 090 apps to 091 without problems.  Under AIR you may get an error:

 

Invalid application descriptor:

Descriptor version does not match runtime version

 

In your application XML file (myapp-app.xml), you will need to change the <application> xml node from 2.5 to 2.0.

 

Seems odd, since the installer asked where 2.5 (Hero) was, but at least the applications runs now.

Developer
Posts: 137
Registered: ‎10-26-2010
My Device: Bold 9900 + PlayBook
My Carrier: Rogers

Re: New SDK Available

Agreed. It appears the simulator is the same build as before.

RIM: Given we know that partner developers already have a new simulator, when can we expect an update?
--------
Taylor Byrnes
Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: New SDK Available

Will release notes for the 091 SDK be available or do we need to hunt around to see what may have changed?

Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: New SDK Available

from the looks of it we're gonna hafta hunt around. my initial hunt has come back as fruitless. nothing jumps out as changed. its prolly all internal and bug fixes. we're prolly gonna hafta wait till at least the webcast on thursday.

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
BlackBerry Development Advisor
Posts: 417
Registered: ‎10-27-2010
My Device: PlayBook

Re: New SDK Available

Release Notes for 0.9.1

http://docs.blackberry.com/en/developers/deliverables/21880/

 

 

This release does not have any API changes and runtime changes (old simulator).

The only new things are official support for Windows 64, Linux and Flash Buidler 4.5

Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: New SDK Available

i stand corrected. Thanks Elena!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: New SDK Available

I downloaded the latest AIR SDK (assume to be 2.5) and reinstalled BB SDK and the -app.xml file issue with the 2.0 and 2.5 version went away.  All projects are 2.5 and install fine with simulator.  So if anyone has this problem, you probably did not stall the 0.9.1 BB SDK with the correct version of Hero or AIR SDK.