Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Highlighted
New Contributor
Posts: 9
Registered: ‎01-26-2011
My Device: Not Specified

PlayBook 0.9.2 Simulator stuck at welcome screen

The PlayBook simulator version 0.9.2 just hangs after starting.  What could the problem be?  

Thanks!

playbookwelcome.jpg

Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

[ Edited ]

The 0.9.2 simulator is very buggy and freezes often.  There has been several threads on this.  Normall I just have to restart the sim and it will start up fine until something freezes it again.  Some have had to reinstall.

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

[ Edited ]

@jetsme, please do a basic forum search before posting new queries.  In this case "simulator stuck" finds a half dozen, which cover the three basic cases of freezing that are known. 

 

One of those relates to using the wrong parameters when building your VM (less than 4GB disk image size, where 8GB is what you should use).  If that's your issue, it's fixable.  (We can't see the image until a moderator approves it so your description of "stuck" and "just hangs" isn't useful.)

 

The second issue (stuck at PB splash screen) affects many and may not be something you can work around.  Some report success with waiting a very long time (hours) and then it continues.  (No idea yet if, when they do that, they can subsequently reboot and have it work properly.)  Others say they've had luck by making sure not to click in the VM window until it's fully booted.  At least one other switched to using Linux for the simulator and it worked there for him.

 

The final issue is a true freeze, where after working fine for a while the sim just stops in its tracks with no further activity.  This is also a known issue covered by past threads.  Reset and start over is the workaround, and wait for the next release.


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
New Contributor
Posts: 9
Registered: ‎01-26-2011
My Device: Not Specified

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

Thanks for the quick response!  I've tried restarting without luck but I've seen some posts where RIM has acknowledged the issue in the current release.

New Contributor
Posts: 9
Registered: ‎01-26-2011
My Device: Not Specified

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

Thanks for the reply and suggestions.  Believe me, that was the first thing I did.  I guess I should not rely on the suggested links that pop up and should instead click on the "Search" button.

 

Thanks again...

Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

Hope you can get your sim to work, because an updated sim may be a ways out if the time to get the latest release is any indication.

New Contributor
Posts: 9
Registered: ‎01-26-2011
My Device: Not Specified

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

I hope so too!  I'm trying some of the suggestions and changing some of the VMWare Player settings.  I'm running Windows 2003, so not sure if that could be the problem, although the previous sim did work.  The issue I had was that the deployment for the Sketch sample did not succeed.  I then found some posts that suggested the latest SDK has to be used with the latest simulator.  I guess the other option is to go back to the old simulator and try debugging the deployment there.

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

To the best of our knowledge (and I believe RIM has stated this too, in the form of one of Elena's messages), you have to use the SDK and simulator as a matched set right now.  Use the old with the old and the new with the new.

 

It sounds from your last message like you're getting past the boot screen and the splash screen, and this is neither of those issues.  If that's so, if it runs fine for a while then freezes, it's the third case I mentioned.  If it just freezes instantly on launching the app, then I think you may have a different issue altogether and one probably related to either the SDK/sim mix, or your own issue.  Nobody else has reported a sim bug involving apps freezing instantly on launch (to my knowledge).


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Contributor
Posts: 20
Registered: ‎01-19-2011
My Device: Not Specified

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

Mine literally takes hours to load. It wont load on a reset either. It has to be powered off and then booted again. Im talking like 4+ hours to load. I just use the built in/flash player/desktop/whatever version to develop on and then do a final check with the simulator. Another note is if you don't need the newest sim you can have both or them installed at the same time (0.91 & 0.92). You have to change your settings in Eclipse and recompile but at least you don't have to uninstall and reinstall.

New Contributor
Posts: 9
Registered: ‎01-26-2011
My Device: Not Specified

Re: PlayBook 0.9.2 Simulator stuck at welcome screen

Hey Peter,

It's the second issue you mentioned - stuck at the PB splash screen with the white light going back and forth along the line below the logo.

Thanks again...