Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
wmatt
Posts: 125
Registered: ‎10-02-2011
My Device: Playbook
Accepted Solution

PlayBook app on Dev Alpha simulator - Exec format error

I'm trying to run my app on the BB10 simulator from Flash Builder. It seems to install with some success (creates an icon in the simulator). But my app fails to launch and gives this error:

Failed to create application process: Exec format error

Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: PlayBook app on Dev Alpha simulator - Exec format error

Did you run it in debugger and did that give more information?
Developer
wmatt
Posts: 125
Registered: ‎10-02-2011
My Device: Playbook

Re: PlayBook app on Dev Alpha simulator - Exec format error

That's the only error I get running it in debug from Flash Builder. Do you use a different debugger?

Developer
wmatt
Posts: 125
Registered: ‎10-02-2011
My Device: Playbook

Re: PlayBook app on Dev Alpha simulator - Exec format error

I installed the app on the simulator via command line and it works. But I can't run it from Flash Builder. 

Developer
wmatt
Posts: 125
Registered: ‎10-02-2011
My Device: Playbook

Re: PlayBook app on Dev Alpha simulator - Exec format error

I also tried the PlayBook simulator and got the same error message, plus the PlayBook simulator displays 'error 8'. So it seems like both the Dev Alpha and PlayBook simulators are having the same problem.

Developer
wmatt
Posts: 125
Registered: ‎10-02-2011
My Device: Playbook

Re: PlayBook app on Dev Alpha simulator - Exec format error

Finally got it working by changing the Network Adapter settings in VMware (change 'Share with my Mac' to Ethernet). Restarted the simulator and put the new IP Address in Flash Builder's run cunfiguration.