Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Andiamo
Posts: 39
Registered: ‎05-26-2009
My Device: BlackBerry Storm 9550
Accepted Solution

Playbook Simulator not able to access the internet

Hi,

 

I am trying to get the Playbook Simulator running to repackage an app but I'm having trouble getting the Simulator to connect to the internet.  The Browser refuses to connect and simply displays a message stating:

 

Error
A network error occurred.
Please try again later.

 

I've tried a few things, like changing the Network Adapter settings in VMware from the default (NAT) to Bridged, and then restarting the virtual machine, but that didn't do anything. I tried removing the Network Adapter from the VM and then adding a new one.  I've disabled Norton Internet Security's firewall and intrusion prevention.  I've disabled Windows Firewall.  None of that fixed the issue.

 

I'm using a Windows 7 laptop connected to a wireless network.  No proxy or VPN is in use.  Windows 7's network adapters screen shows two VMware Adapters, vmnet1 and vmnet8, both connected to an "Unidentified Network."  I tried bridging those adapters with my PC's wireless adapter but the VMware adapter didn't allow that and threw an error.

 

Any suggestions?

Please use plain text.
Contributor
CaptainN
Posts: 18
Registered: ‎02-08-2012
My Device: PlayBook
My Carrier: AT&T

Re: Playbook Simulator not able to access the internet

[ Edited ]

I had the same problem and couldn't find a resolution - except that the Playbook 2.0 (beta) simulator doesn't have this problem.

Please use plain text.
New Contributor
adamchappell
Posts: 4
Registered: ‎02-11-2012
My Device: Blackberry Torch 9800
My Carrier: Vodafone

Re: Playbook Simulator not able to access the internet

Some basics: check it has an IP address on vmnet8. Check you can ping that from your host OS.

 

If it still doesnt work, switch off developer mode (About -> Security), then try the browser again. Yes, I know this seem counter-intuitive, but it worked for me.

 

You can re-switch on developer mode, once you've turned it off and it seems fine. Not sure quite why this is happening, but it might be useful to take a VM snapshot once you've cracked it.

 

Good luck!

 

Please use plain text.
New Contributor
adamchappell
Posts: 4
Registered: ‎02-11-2012
My Device: Blackberry Torch 9800
My Carrier: Vodafone

Re: Playbook Simulator not able to access the internet

Actually, having seen this problem several times now, I can tell you that Development seems to have nothing to do with it.

But pinging the Playbook from the VM host is the killer. When I do this, the browser spins into life.

Seems there is, perhaps, some sort of ARP brokenism. Not sure. Or perhaps it's the way my Mac's VMWare Fusion interacts with the Playbook.
Please use plain text.
Developer
Andiamo
Posts: 39
Registered: ‎05-26-2009
My Device: BlackBerry Storm 9550

Re: Playbook Simulator not able to access the internet

Thanks for that, Adam. I pinged the Playbook VM at the IP address listed in the "Development Mode" floating popup and the browser started working perfectly.

Bizarre! But I don't care enough to try and determine the cause. Thanks for your help!
Please use plain text.
New Member
Madhusudhan
Posts: 1
Registered: ‎02-25-2012
My Device: Simulator
My Carrier: Airtel

Re: Playbook Simulator not able to access the internet

Even I had this problem of not being able to connect to internet from with in the Blackberry - playbook - simulator VM , running on top of Ubuntu 11.10 OS

 

SOlution : Note down the IP address of SImulator , ping it from outside the VM , that is ping the IP from Ubutu terminal internet starts working inside Blackberry playbook VM . my network setting is Bridged.

 

I am still unable to understand how pinging from outside can enable network setting inside VM

Please use plain text.