Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
SangramPatil
Posts: 271
Registered: ‎01-21-2013
My Device: BB10 Dev Aplha

Problems in uploading bar to app world

I tried uploading the update to my BB10 AIR app and got the following error:

 

'You are about to overwrite the definition from the Bar Manifest file. This may cause negative customer impacts. Please make sure to update your Bar Manifest to the correct minimum OS.'

 

I choosed QNX and min OS as 10.0 and when I uploaded the bar, it prompts me this message. Is it safe to continue and submit for review? What is this problem and how can I resolve this? I am following the same process for app signing as before and never got this error.

Please use plain text.
Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Problems in uploading bar to app world

[ Edited ]

What was the minimum OS you specified in your bar manifest file and what did you build to?


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Please use plain text.
Trusted Contributor
Sankar_S
Posts: 139
Registered: ‎08-22-2013
My Device: None

Re: Problems in uploading bar to app world

which tool used for your app creating like native sdk or web works sdk and so on?

Please use plain text.
Developer
SangramPatil
Posts: 271
Registered: ‎01-21-2013
My Device: BB10 Dev Aplha

Re: Problems in uploading bar to app world

I didn't manually add any min OS in bar manifest file, I am building it for BB10.

Please use plain text.
Developer
SangramPatil
Posts: 271
Registered: ‎01-21-2013
My Device: BB10 Dev Aplha

Re: Problems in uploading bar to app world

I am using AIR SDK.

Please use plain text.
Developer
SangramPatil
Posts: 271
Registered: ‎01-21-2013
My Device: BB10 Dev Aplha

Re: Problems in uploading bar to app world

Any solution?

Please use plain text.
Developer
pyth
Posts: 506
Registered: ‎01-19-2011
My Device: My Trusty Red Plane

Re: Problems in uploading bar to app world

please open your *.bar-file and fo to META-INF -> MANIFEST.MF

 

there should be a line 'Application-Requires-System'. Maybe you have set the wrong version

 

if you want us to be more precise, copy the contents of your manifest file here, without all your credential information. because with the information given, all we can do is make wild guesses :smileytongue:

-----------------------------------------------------------------------
I'm a bird from outer space. But I'm not flappy o.o
Please use plain text.
Regular Contributor
testworks
Posts: 76
Registered: ‎04-19-2011
My Device: Bold 9700

Re: Problems in uploading bar to app world

I have the same issue on a release I uploaded yesterday. I can't figure out where to set the minimum version in my release file.

 

I suspect they updated App World to extract the version from the manifest as it auto-sets the minimum version to 1.0.8 for me and then complains when I switch it back to 10.x.

 

The manifest generated from Flash Builder contains:

 

Application-Requires-System: BlackBerry 10/1.0.8.0

 

My previous release has the exact same details as above but app world didn't complain about it when I uploaded it last week.

Please use plain text.