Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
BlackBerry Development Advisor
Posts: 15,252
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Read This Before Upgrading to the Final Release of Flash Builder 4.5

[ Edited ]

The final release of Flash Builder 4.5 has removed support for AIR 2.5, which is required for building BlackBerry Tablet OS applications.  RIM's recommendation is to continue using Flash Builder 4.0.1 or Flash Builder Burrito to develop applications for the BlackBerry Tablet OS.  

 

If you do need to upgrade to the final release of Flash Builder 4.5, Adobe has posted an unsupported work around for this issue on their web site.

 

http://blogs.adobe.com/jasonsj/2011/05/flex45_air25_playbook.html

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 249
Registered: ‎11-02-2010
My Device: PlayBook
My Carrier: -

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

[ Edited ]

Hello Mark,

  thank you for the link.

Do you have any information about the next BlackBerry Tablet OS SDK working with AIR 2.6 ?

 

By the way I'd like to thank dev. team at RIM's for the improvment in SDK 1.0.1 about signing process and debug token. Works fine and smooth !

 

 

JC
BlackBerry Development Advisor
Posts: 15,252
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

[ Edited ]

Thanks Acenet!  I will pass this along to the team.  Smiley Happy

 

We're not stopping here though.  There are plans underway to further streamline and simplify the signing process.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 17
Registered: ‎04-22-2011
My Device: Playbook
My Carrier: Fido

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

Adobe might have an update for FB4.5 on Playbook next month as far as I Know.
Developer
Posts: 439
Registered: ‎10-25-2010
My Device: Not Specified

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

Just a heads up, you only need the monkey_patch **bleep** if you're depploying a flex app. If you are doing pure AS3, all you need is the 2 flags.

 

One tricky thing though, if you're using the Mobile ActionScript Project, is you can't actually select the Playbook SDK since it  "Does not support mobile projects".

 

You need to select the Flex 4.5 SDK, and then in your properties > Actionscript Build Packaging > Blackberry Tablet OS, check off "Add platform specific libraries to library path"

New Developer
Posts: 17
Registered: ‎04-22-2011
My Device: Playbook
My Carrier: Fido

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

Thanks for the trick. Tested Flex mobile project and Actionscript mobile project in new FB 4.5, didn't encounter any error, the work around just works.

Contributor
Posts: 30
Registered: ‎01-09-2011
My Device: PlayBook

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

Just to note, Adobe has already announced that an FB4.5.x update in June will add full PlayBook (and iOS) support for Flex mobile projects.  There are more details in this blog post.

 

- Peter

Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

Does the Tablet OS SDK installer support FB 4.5 Standard? Because on the site it says it only supports Premium.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
BlackBerry Development Advisor
Posts: 15,252
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

Flash Builder 4.5 Standard is supported.  Can you provide a link to the page you are referring to?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Read This Before Upgrading to the Final Release of Flash Builder 4.5

http://docs.blackberry.com/en/developers/deliverables/21880/Product_information_1589456_11.jsp

Under "BlackBerry Tablet OS SDK Plug-in for Flash Builder product information"

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.