Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Developer
markstar
Posts: 5
Registered: ‎02-21-2011
My Device: Not Specified
Accepted Solution

Splashscreen not appearing

Hi guys,

 

The splash screen on my application is not appearing, maybe one of you can help me get it to appear!

 

Below is a copy of my blackberry-tablet.xml file:

 

<qnx>
  <initialWindow>
  <systemChrome>none</systemChrome>
  <transparent>false</transparent>
  <autoOrients>false</autoOrients>
  <aspectRatio>landscape</aspectRatio>
  </initialWindow>
  <publisher>Mark Starling</publisher>
  <category>core.internet</category>
  <splashscreen>splashscreen.png</splashscreen>
</qnx>

 

The splashscreen.png file resides in the 'src' folder, as specified by a few docs I've read.

 

I've tried naming the file different names, but that didn't seem to make a difference. I've also extracted the .bar file to confirm that the bar file contains the splashscreen.png file and the blackberry-tablet.xml file.

 

Should I be able to see the splashscreen in debug mode?

 

Also, does anyone know how to install a .bar file once you have one compiled, or can I only do this through the 'run application' and 'debug application' options in Flash Builder?

 

Cheers,

 

Mark

Please use plain text.
Developer
jffurlan
Posts: 1,003
Registered: ‎01-16-2011
My Device: PlayBook (sim)

Re: Splashscreen not appearing

Are you positive you are running the latest sdk (or at least 0.9.2)? I had updated both my sdk and simulator but forgot to update my project to 0.9.2 and therefore my splashscreen would not appear.

 

I believe a .bar file can be installed through the command line, but don't ask me how to do it lol!

- If you like my response/post, or it helped you find an answer you were looking for, please provide a Kudo - white star to the bottom right of this post. -
- Please use the search bar at the top, or check out the PlayBook FAQ's for help getting started -
- Hockey DrillBook -
Please use plain text.
New Developer
markstar
Posts: 5
Registered: ‎02-21-2011
My Device: Not Specified

Re: Splashscreen not appearing

Excellent, I had installed the latest SDK and simulator (0.9.3) but my project had not been set to build against the 0.9.3 SDK. Updated it and my splashscreen appeared! Thank you!

Please use plain text.
Developer
jffurlan
Posts: 1,003
Registered: ‎01-16-2011
My Device: PlayBook (sim)

Re: Splashscreen not appearing

No worries! When I had downloaded the newest sdk it never occured to me I had to update my project so I spent many hours constalling trying to figure out why my Splashscreen never appeared!

 

Mind marking my post as the solution so that others with this problem will be able to find an answer quickly?

- If you like my response/post, or it helped you find an answer you were looking for, please provide a Kudo - white star to the bottom right of this post. -
- Please use the search bar at the top, or check out the PlayBook FAQ's for help getting started -
- Hockey DrillBook -
Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: Splashscreen not appearing

The splash screen can be seen in debug mode.  Make certain the splash file is in your BAR file (unzip it to view contents).  If it is not, you have to include the splash screen file in your list of files to be included in the BAR file with the blackberry-airpackager command.

Please use plain text.
Contributor
eldes
Posts: 13
Registered: ‎03-05-2012
My Device: PlayBook

Re: Splashscreen not appearing

I'm having a similar problem.

 

I checked the contents of the BAR (ZIP) and the splashscreen image is inside. But when running the app the image does not appear.

 

The blackberry-tablet.xml:

 

<!-- previously known as blackberry-tablet.xml until os 2.0 -->
<qnx>
<initialWindow>
<systemChrome>none</systemChrome>
<transparent>true</transparent>
<visible>true</visible>
<autoOrients>true</autoOrients>
<aspectRatio>portrait</aspectRatio>
</initialWindow>


<publisher>frux.com.br</publisher>
<author>Frux Design</author>
<authorId>[xxxxxx]</authorId>
<buildId>1000</buildId>
<platformVersion>2.0.0.0</platformVersion>
<category>core.games</category>
 <icon>
<image>Icon_86.png</image>
</icon>

<splashscreen>blackberry-splash.png</splashscreen>
</qnx>

Please use plain text.
Developer
JohnPinkerton
Posts: 350
Registered: ‎01-21-2011
My Device: Curve 8900 (Personal) / Bold 9650 (Work)

Re: Splashscreen not appearing

You should really start your own thread, especially seeing as how this one is over a year old. Check the case on your extension (png vs PNG)

Please use plain text.
Developer
pyth
Posts: 506
Registered: ‎01-19-2011
My Device: My Trusty Red Plane

Re: Splashscreen not appearing

yes, or maybe it's just removing the hyphen (the   -  )

-----------------------------------------------------------------------
I'm a bird from outer space. But I'm not flappy o.o
Please use plain text.
Contributor
eldes
Posts: 13
Registered: ‎03-05-2012
My Device: PlayBook

Re: Splashscreen not appearing

Thank you JohnPinkerton and Pyth.

 

I removed the hyphen and checked the case on the file extension: all right in both cases, but has not worked yet.

Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: Splashscreen not appearing

What is the path to the PNG? Is it under your assets folder?
Please use plain text.