If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
alinium
Posts: 31
Registered: ‎12-25-2010
My Device: PlayBook
My Carrier: Rogers
Accepted Solution

Still having icon problems

Hey guys,

 

My app got rejected for a second time because of icon not showing up. I don't know what I'm doing wrong. Can anyone help out??

 

For v1.0.0, my icon wasn't 86x86. So I submitted a v1.0.1 with an 86x86 size icon (I've also attached this icon with this post).

 

Here's what my blackberry-tablet.xml looks like:

 

<qnx>
   <icon>
    <image>icon_playtext_86.png</image>
   </icon>
   <publisher>Muhammad Ali</publisher>
   <category>core.media</category>
   <splashscreen>splash.png</splashscreen>
   <permission>access_shared</permission>
   <permission>access_internet</permission>
</qnx>
I also left the icon tag in the app.xml uncommented. Could this have caused the problem? Here is the relevant bit from my PlayText-app.xml:
    <icon>
        <!--<image16x16>icon_playtext_16.png</image16x16>
<image32x32>icon_playtext_32.png</image32x32>
<image36x36>icon_playtext_36.png</image36x36>
<image48x48>icon_playtext_48.png</image48x48>
<image72x72>icon_playtext_72.png</image72x72> -->
        <image128x128>icon_playtext_128.png</image128x128>
    </icon>
Should I completely comment out the <icon> tag in the app.xml? Will that fix the problem?
I also just realized that at the bottom of my app.xml is a <qnx> section which is the same as the content I put in blackberry-tablet.xml. However, I don't remember adding this section here in the PlayText-app.xml. Does this get added on automatically??
I'm just trying to figure out why my app icon isn't showing up when the reviewers are testing my app. I'm sure my icon is 86x86 - I've attached it with this post - can someone else please confirm too, just in case I'm going crazy....
I don't know what's wrong. I want to make sure I fix the problem before submitting another version. BTW, when I deploy my v1.0.1 to the simulator, the icon shows up properly. So I have really no idea why it isn't working for the reviewer. Any ideas?
The reviewer's comment was:
"Application icon not displaying on PlayBook. Please resize app icon to 86x86 and submit a new release for review."

 

_________________
My apps: PlayText
Please use plain text.
Developer
cas118
Posts: 860
Registered: ‎10-27-2010
My Device: Z30 / PlayBook 64GB
My Carrier: Virgin Mobile UK

Re: Still having icon problems

Is the icon being included in the packages .bar file?

And have you tried to load the release version of the .bar onto the simulator?

Follow me on Twitter1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
Please use plain text.
Developer
steve_web
Posts: 320
Registered: ‎05-07-2009
My Device: BlackBerry Z10, PlayBook, 9900
My Carrier: Telus

Re: Still having icon problems

[ Edited ]

I have this in all my apps and it works just fine (note the image is exactly 86x86 pixels)

 

<qnx>
   <icon>
     < image >blackberry-tablet-icon.png</image>
   </icon>

   ....
 </qnx>

 

ignore the space around the image opening tag above, the forum software won't let me delete the spaces :-(


PlayBook Apps: DataMine, Dots + Boxes, 5 Marbles
BlackBerry SmartPhone Apps: 5 Marbles Soon: **** (D.Z.A), ****Quest, **** Challenge, VaultCracker, DevBrowser, Radial****
Please use plain text.
Developer
alinium
Posts: 31
Registered: ‎12-25-2010
My Device: PlayBook
My Carrier: Rogers

Re: Still having icon problems

 


cas118 wrote:
Is the icon being included in the packages .bar file?

And have you tried to load the release version of the .bar onto the simulator?

 

Yes it is being included in the bar file. I've opened it with 7zip to confirm. Its inside the 'air' folder in the bar.

 

And yes, I've loaded the release version of the .bar into the simulator too. It shows up as another app (one is from my development version from FlashBuilder and the other from the release version of the bar). Both have the correct icon showing up:

playtext.png

_________________
My apps: PlayText
Please use plain text.
Developer
alinium
Posts: 31
Registered: ‎12-25-2010
My Device: PlayBook
My Carrier: Rogers

Re: Still having icon problems

 


steve_web wrote:

I have this in all my apps and it works just fine (note the image is exactly 86x86 pixels)

 

<qnx>
   <icon>
     < image >blackberry-tablet-icon.png</image>
   </icon>

   ....
 </qnx>

 

ignore the space around the image opening tag above, the forum software won't let me delete the spaces :-(


 

Thanks, I guess I will try renaming the file to 'blackberry-tablet-icon.png' instead of some custom name.

 

Any other ideas from others?

_________________
My apps: PlayText
Please use plain text.
Developer
jffurlan
Posts: 1,003
Registered: ‎01-16-2011
My Device: PlayBook (sim)
My Carrier: Rogers

Re: Still having icon problems

I wouldn't comment out the -app.XML section, but I'd also leave that 128 size blank. That way at no point will it be confused about what to load.

I also secod steve_web as my icons only work when I use that naming convention.
- If you like my response/post, or it helped you find an answer you were looking for, please provide a Kudo - white star to the bottom right of this post. -
- Please use the search bar at the top, or check out the PlayBook FAQ's for help getting started -
- Hockey DrillBook -
Please use plain text.
Developer
cas118
Posts: 860
Registered: ‎10-27-2010
My Device: Z30 / PlayBook 64GB
My Carrier: Virgin Mobile UK

Re: Still having icon problems

I've submitted an app with my own filename. Maybe the real PlayBook doesn't like underscores? Anyone else used underscores in their icon file?

Follow me on Twitter1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: Still having icon problems

You dont have to rename it, it just needs to ONLY be placed in the blackberry-tablet.xml file.

Please use plain text.
Contributor
ytpete
Posts: 30
Registered: ‎01-09-2011
My Device: PlayBook

Re: Still having icon problems

In the final step of the signing wizard, did you make sure the .png file was checked off for inclusion in the BAR?  If you want to double check, copy your signed .bar file, rename it to .zip, and make sure your icon file is in the expected place and has the expected filename.

 

Hope that helps,

 

- Peter

Please use plain text.
Developer
alinium
Posts: 31
Registered: ‎12-25-2010
My Device: PlayBook
My Carrier: Rogers

Re: Still having icon problems

 


jtegen wrote:

You dont have to rename it, it just needs to ONLY be placed in the blackberry-tablet.xml file.


So its safe to completely comment out the <icon> section from app.xml, and only have the <icon> be specified in the blackberry-tablet.xml?

 

_________________
My apps: PlayText
Please use plain text.