Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Smugrik
Posts: 185
Registered: ‎04-05-2011
My Device: PlayBook
Accepted Solution

Which AIR SDK version to use for BB10

Hi,

 

I recently moved my dev environment to a new Mac, so I had to reinstall everything, I installed the BB sdk 3,0 and pointed it to AIR sdk 3,4, I can compile an app, I migrated all signing and Debug Tokens (all of which is alright, Cascaes app are OK), but whenever I try to launch my AIR app on the BB10, it opens and immediately quits before anything, even a simple HelloWorld fails.

 

Is it because I compiled against AIR sdk 3.4?

 

The dev sites clearly states "Adobe AIR SDK 2.6 or later", so what am I missing?

 

Thanks!

Julien
Web: smugrik.org Follow: @Smugrik
PlayBook apps:
OSCream
kiPass
Developer
UberschallSamsara
Posts: 1,029
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Which AIR SDK version to use for BB10

[ Edited ]

There has been some confusion about this recently, and IMO RIM should clear it up so that your experience is not repeated.  

 

My understanding from other threads on this is that the installer asks you for a path to an AIR SDK that is version 2.6 or greater (it's been a long time since I last installed so I'm going on the comments of others).

 

However the system requirements on the AIR BB10 SDK state you need  AIR 3.1 or higher:

 

https://developer.blackberry.com/air/beta/download/requirements/

 

And on top of that, my understanding is that AIR 3.4 support won't be in BB10 for a while as it's not top priority.

 

So, based on what seems to be working for me and for others, I'd recommend you grab the 3.1 AIR SDK and

reinstall your BB10 SDK from scratch, integrating it with your AIR 3.1 SDK, if that won't cause too many problems

for you.

 

RIM, please get your system requirements in sync across all SDK installers, system requirements web

pages, etc.  Basic issues like this one should not be tripping up one developer after another.

 

Developer
Smugrik
Posts: 185
Registered: ‎04-05-2011
My Device: PlayBook

Re: Which AIR SDK version to use for BB10

Thanks, this confirms what I was thinking, can't seem to find a link to an older AIR SDK on adobe site, evrything redirects to 3.4...

Julien
Web: smugrik.org Follow: @Smugrik
PlayBook apps:
OSCream
kiPass
Developer
UberschallSamsara
Posts: 1,029
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Which AIR SDK version to use for BB10

I found this link to legacy SDK downloads with a quick web search:

 

http://helpx.adobe.com/air/kb/archived-air-sdk-version.html

Developer
Smugrik
Posts: 185
Registered: ‎04-05-2011
My Device: PlayBook

Re: Which AIR SDK version to use for BB10

:-) my bad, I admit I didn't googled past the first 3 results of "air sdk 3.3" on that one...

thanks for the link, will try and report...

Julien
Web: smugrik.org Follow: @Smugrik
PlayBook apps:
OSCream
kiPass
Developer
Smugrik
Posts: 185
Registered: ‎04-05-2011
My Device: PlayBook

Re: Which AIR SDK version to use for BB10

I uninstalled everything, and re-installed again using AIR SDK 3.3, but still no luck...

So I checked my -app.xml descriptor file and changed the first line version from 3.3 to 3.1

 

<applicationxmlns="http://ns.adobe.com/air/application/3.3">

 

<applicationxmlns="http://ns.adobe.com/air/application/3.1">

 

This did the trick, my app now launches normally, though the AIR SDK is still 3.3, this is a bit weird... I thought BB10 was on AIR 3.3

Julien
Web: smugrik.org Follow: @Smugrik
PlayBook apps:
OSCream
kiPass
Retired
dmalik
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook

Re: Which AIR SDK version to use for BB10

Right now we currently only support AIR version 3.1. As Tim mentioned here we will be updating to either 3.3 or 3.4 in the future.

 

I will test this but your application should build if you have the latest SDK installed and target AIR 3.1. 

 

I will make sure that we clear up any confusion in our documentation and SDK installer.

 

Regards,

Dustin

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Retired
dmalik
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook

Re: Which AIR SDK version to use for BB10

It seems I'm wrong and you will need the 3.1 AIR SDK. I believe AIR 3.1 is installed by default in Flash Builder 4.6 though. I will talk to the docs team about making it more clear for developers. 

 

Cheers,

Dustin

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Developer
UberschallSamsara
Posts: 1,029
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Which AIR SDK version to use for BB10

[ Edited ]

@dmalik - thanks!

 

Please advise the docs folks to make sure the developer guides and system requirements pages for the commandline tools and other non-Adobe tools are updated to match.

Developer
Smugrik
Posts: 185
Registered: ‎04-05-2011
My Device: PlayBook

Re: Which AIR SDK version to use for BB10

Thanks for clarification,

 

Few precisions, I'm using FDT, and I compiled with AIR 3,3 but with 3,1 namespace, and succesfully deployed my app to BB10 Dev Alpha...

 

Just to avoid any possible incompatibility problems, I'll reinstall 3,1 SDK ...

Julien
Web: smugrik.org Follow: @Smugrik
PlayBook apps:
OSCream
kiPass