Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Developer
alexperri7
Posts: 325
Registered: ‎10-28-2010
My Device: Blackberry Bold 9900
My Carrier: Telus
Accepted Solution

app not working when deploying with 0.9.4

Hi guys. I had originally created my app using the 0.9.3 sdk and had no problems. I submitted my app and it was approved, but now I am trying to re-submit it with 0.9.4 and I can't even get it to deploy to the simulator. I get this error message:

 

Deployment Failed: Sending Launch request...
Info: Action: Launch
Info: Launching PocketPhotoOrg.debug.testaG90b09yZy5kZWJ1ZyAgICA...
result::Failed
Info: done

 

I also get this error message when I run it in on the desktop:

 

VerifyError: Error #1014: Class qnx.pps::smileytongue:PSChannel could not be found.

    at test2/___test2_MobileApplication1_creationComplete()[/Users/AP_Photography/Documents/Adobe Flash Builder Burrito Preview/test2/src/test2.mxml:6]
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at mx.core::UIComponent/dispatchEvent()[E:\dev\hero_private_beta\frameworks\projects\framework\src\mx\core\UIComponent.as:12977]
    at mx.core::UIComponent/set initialized()[E:\dev\hero_private_beta\frameworks\projects\framework\src\mx\core\UIComponent.as:1757]
    at mx.managers::LayoutManager/doPhasedInstantiation()[E:\dev\hero_private_beta\frameworks\projects\framework\src\mx\managers\LayoutManager.as:819]
    at mx.managers::LayoutManager/doPhasedInstantiationCallback()[E:\dev\hero_private_beta\frameworks\projects\framework\src\mx\managers\LayoutManager.as:1157]

 

Could anyone tell me why this is happening? I have already had 3 apps approved. This is the first time I've run into this problem, and all my other apps ran smoothly with 0.9.4, signing and everything.

---------------------------------
My PlayBook Apps: Pocket Portrait Lighting, Pocket Food Photography, Allergen Free Cooking, Easy Agenda
Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: app not working when deploying with 0.9.4

LayoutManager, like a lot of QNX classes like this, depend on PPS which is a service not available outside the simulator or device.  You will need to run this on the device (or use the API clone in the community library -v3 that was just released).

Please use plain text.
New Developer
alexperri7
Posts: 325
Registered: ‎10-28-2010
My Device: Blackberry Bold 9900
My Carrier: Telus

Re: app not working when deploying with 0.9.4

Is this only an issue with 0.9.4? I had no problem running it on my simulator when I compiled with 0.9.3.

---------------------------------
My PlayBook Apps: Pocket Portrait Lighting, Pocket Food Photography, Allergen Free Cooking, Easy Agenda
Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: app not working when deploying with 0.9.4

Same thing happen with TextInput.

 

Wish they either support some kind of PPS outside the device so people can be more productive in AIR or capture these errors inside the API so we dont have to continue creating work arounds.  I'm surprised the RIM/QNX developers in AIR can work this way.

Please use plain text.
New Developer
alexperri7
Posts: 325
Registered: ‎10-28-2010
My Device: Blackberry Bold 9900
My Carrier: Telus

Re: app not working when deploying with 0.9.4

Sorry John I'm still unclear about one thing. Is this an issue that just happened with the 0.9.4 sdk because I haven't changed anything in my app. All I did was changed everything to point to the 0.9.4 sdk. Nothing else was changed, and these errors did not exist when using 0.9.3. My app was, afterall, signed and approved with the previous sdk.

---------------------------------
My PlayBook Apps: Pocket Portrait Lighting, Pocket Food Photography, Allergen Free Cooking, Easy Agenda
Please use plain text.
BlackBerry Development Advisor
elena_laskavaia
Posts: 417
Registered: ‎10-27-2010
My Device: PlayBook

Re: app not working when deploying with 0.9.4

Try to uninstall previous app and install from the scratch. If you try to deploy your signed app which you did with 0.9.3 on 0.9.4 sim does it launch?

Please use plain text.
Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: app not working when deploying with 0.9.4

@alex: You only get the PPS error when you are running your application in the Desktop right? Are you using any QNX components in your application?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Please use plain text.
New Developer
alexperri7
Posts: 325
Registered: ‎10-28-2010
My Device: Blackberry Bold 9900
My Carrier: Telus

Re: app not working when deploying with 0.9.4

Thanks elena. I will try this and post my results.

---------------------------------
My PlayBook Apps: Pocket Portrait Lighting, Pocket Food Photography, Allergen Free Cooking, Easy Agenda
Please use plain text.
New Developer
alexperri7
Posts: 325
Registered: ‎10-28-2010
My Device: Blackberry Bold 9900
My Carrier: Telus

Re: app not working when deploying with 0.9.4

@JRab,

 

Yes I only get the PPS error when running in the desktop. I just get the failed error when trying to deploy to the simulator. It is the application that you helped me sort out, with saving the states that contain text inputs and check boxes. It uses the persistence manager to save states and it has a swipe down menu.

---------------------------------
My PlayBook Apps: Pocket Portrait Lighting, Pocket Food Photography, Allergen Free Cooking, Easy Agenda
Please use plain text.
New Developer
alexperri7
Posts: 325
Registered: ‎10-28-2010
My Device: Blackberry Bold 9900
My Carrier: Telus

Re: app not working when deploying with 0.9.4

So I tried to uninstall my app from terminal and it said Error: Authentication failed due to invalid password. Do I need to type in a password to uninstall? Right now, this is the command that I am using:

 

./blackberry-deploy -uninstallApp -package PocketPhotoOrganizer.bar -device 192.168.148.139

---------------------------------
My PlayBook Apps: Pocket Portrait Lighting, Pocket Food Photography, Allergen Free Cooking, Easy Agenda
Please use plain text.