Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: icon issue continually leading to rejection

And do you have "blackberry-tablet-icon.PNG" in your /src folder?
Please use plain text.
New Developer
thedocdre00
Posts: 15
Registered: ‎09-29-2012
My Device: Developer
My Carrier: AT&T

Re: icon issue continually leading to rejection

yup 

Please use plain text.
Developer
UberschallSamsara
Posts: 1,003
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: icon issue continually leading to rejection

So is the file extension uppercase (".PNG") or lowercase (".png") on the actual filename?

 

QNX is a POSIX compliant system and filenames are case sensitive.

Please use plain text.
Developer
UberschallSamsara
Posts: 1,003
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: icon issue continually leading to rejection

Just curious, why do you have your <qnx> root node existing in your *-app.xml file instead of in your bar-descriptor.xml file?

 

Your *-app.xml file needs to have a <application> node in it with the correct AIR namespace:

 

<application xmlns="http://ns.adobe.com/air/application/3.1">

 This is an Adobe AIR thing, not a BlackBerry QNX thing.

Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: icon issue continually leading to rejection

I think Uber... got it. The QNX XML root file should be named "bar-descriptor.xml" and your AIR files should be the "countdown-app.xml" name which sould be the <application> root node with the namespace version of 3.1.

Good catch.
Please use plain text.
New Developer
thedocdre00
Posts: 15
Registered: ‎09-29-2012
My Device: Developer
My Carrier: AT&T

Re: icon issue continually leading to rejection

Thanks Uber!! That FINALLY worked. But I feel reallyyyy dumb, and the fact that I can't get the app name to omit the "-debug" in the simulator is only making it worse. Any help for that?

Please use plain text.
Developer
UberschallSamsara
Posts: 1,003
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: icon issue continually leading to rejection

Are you building the app in debug configuration or release configuration?

Please use plain text.
New Developer
thedocdre00
Posts: 15
Registered: ‎09-29-2012
My Device: Developer
My Carrier: AT&T

Re: icon issue continually leading to rejection

I'm not sure, but it seems running in debug would explain the problems. How do i change to the final- release config?

it's clearly my first time with air
Please use plain text.
Developer
UberschallSamsara
Posts: 1,003
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: icon issue continually leading to rejection

[ Edited ]

Try the steps in this knowledgebase article to switch the application deployment mode from Development mode to Production mode.

Please use plain text.
New Developer
thedocdre00
Posts: 15
Registered: ‎09-29-2012
My Device: Developer
My Carrier: AT&T

Re: icon issue continually leading to rejection

Sorry to be a bother but i'm not seeing that option, to change the deployment mode
Please use plain text.