Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Developer
Posts: 47
Registered: ‎02-09-2011
My Device: BlackBerry PlayBook
My Carrier: N/A
Accepted Solution

manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

[ Edited ]

Hey everyone. Recently had my app accepted into the App World, and now I have to finally get around to signing my application. I followed the steps listed HERE, and all was well until I went to actually sign my BAR... it throws the following error:

 

manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

 

I searched around the forums and found this (which also led to this), but I ran into another problem. I've been working off of my Flex Mobile Project using the Hero SDK, and all seemed to go well. It debugged fine, the installed BAR was fine, and most importantly, it was accepted by RIM. I figured it was no big deal, but now I'm running into issues. The threads I linked to had an official developer response of running off of the latest SDK (0.9.3), but my project says that the SDK is incompatible with Mobile Projects.


Anyone have any suggestions? I'm hoping I don't have to redo anything here, but I figure I'll do whatever I have to do get my app up and running as it should be. Thanks in advance guys!

 

Edit: another suggestion was to actually go into my manifest file in META-INF and delete that line of text. I can do this, but I have no idea what effect it'll have and I assume you guys are far, far smarter than me. If I try going around and screwing with my files, it can't end up well. Smiley Very Happy

----------------------------------------------------------------------------------
If you wanna give my Playbook app a look, that'd be pretty cool. Smiley Happy It's easyTrans in the App World.
Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

hey,

 

what version of the SDK are you using? the only way to sign your app is by compiling it against the 0.9.3 SDK. the older ones are not supported. what error are you getting when you install the new sdk? and what IDE were u using prior to the 0.9.3 release?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Developer
Posts: 47
Registered: ‎02-09-2011
My Device: BlackBerry PlayBook
My Carrier: N/A

Re: manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

 


JRab wrote:

hey,

 

what version of the SDK are you using? the only way to sign your app is by compiling it against the 0.9.3 SDK. the older ones are not supported. what error are you getting when you install the new sdk? and what IDE were u using prior to the 0.9.3 release?


 

I've been using Burrito the entire time, just with the Flex Hero SDK being compiled against. I guess I thought I had to use a mobile project (sign one I'm not too bright), so I just ignored the BB SDK and everything worked fine. I probably could have had a bit  more foresight and realized that it'd affect me somewhere down the road. I have all of the SDK's installed, but if I try to change what my app compiles against, I'm told 0.9.3's incompatible with mobile projects (I'm using a Flex Mobile Project).

 

Thanks for your response!

----------------------------------------------------------------------------------
If you wanna give my Playbook app a look, that'd be pretty cool. Smiley Happy It's easyTrans in the App World.
Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

haha what do you mean you arent too bright. you actually made the right decision there. in the first step of the project creation you have to choose the Flex Hero SDK. You cannot choose the BB SDK because it only works as a reference library.

 

If you go to Preferences > Flash Builder > Target Platforms what do you see there?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Highlighted
Developer
Posts: 53
Registered: ‎02-22-2011
My Device: Blackberry Torch 9800
My Carrier: The one I'm on

Re: manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

Hey Wallord,

 

I was running into similar issues last night when i was trying to sign my application. However I was using the Blackberry SDK 0.9.2 which worked fine with a mobile application. When 0.9.3 came out i tried changing my compiler version and it told me that mobile projects aren't compatible with 0.9.3. 

 

thankfully jrad responded to my post and his third link did the trick: Signing and testing your app.

 

the only problem you may encounter is if the Hero SDK has function and classes that aren't support by the BB compiler.

 

Good luck,

David

David

Twitter: dmbproduction
Playbook App: Food Journal
New Developer
Posts: 47
Registered: ‎02-09-2011
My Device: BlackBerry PlayBook
My Carrier: N/A

Re: manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

 


JRab wrote:

haha what do you mean you arent too bright. you actually made the right decision there. in the first step of the project creation you have to choose the Flex Hero SDK. You cannot choose the BB SDK because it only works as a reference library.

 

If you go to Preferences > Flash Builder > Target Platforms what do you see there?


Mmk, so now I feel dumb again. All fixed now (and, for future Googlers, use the above and make sure it's on 0.9.3 and not something older!). I guess I'll use this as a quick learning experience - what sort of terminology would you use for Flex Hero in this case? I thought that's what I was compiling against (as it was in the build path), but I guess I'm using the wrong term.

 

----------------------------------------------------------------------------------
If you wanna give my Playbook app a look, that'd be pretty cool. Smiley Happy It's easyTrans in the App World.
Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: manifest error: Invalid value '1.0.0.0' for Application-Requires-System.

hey,

 

now that you have the correct library referenced, just follow the steps in the thread that @dmbproduction linked to which then links to this thread:

 

http://supportforums.blackberry.com/t5/Tablet-OS-SDK-for-Adobe-AIR/Useful-Tip-Package-Images-Via-Com...

 

make sure that you are using the commands in the 0.9.3 bin directory and nowhere else. also the trick here is to not use the GUI for any packaging or signing. there is a bug that currently is very misleading and does not do anything that the developer intended. so go to that thread and read it carefully and go through each step. those steps are after you registered with the signing server.

 

and no reason to feel dumb, we've all been there. in fact i've been tricked by that too. all my projects were referencing the 0.9.1 one time. was a puzzle!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman