Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Developer
illuzioner
Posts: 17
Registered: ‎12-04-2010
My Device: BB Tour

sound issues?

Hi,

 

I built my PB app first in Air, and now I'm making the final touches for the PB device itself.  The app works great in Air, but on PB I'm getting two sound issues.

 

The first issue is that I do not hear any sounds at all in my app.  I thought I had seen another post on this, but I can't find it now.  I am creating the (embedded) sounds and playing them without crashes,  but no sound is heard.

 

The second issue relates to the sound channel. 

 

 

                var sound:Sound = new SoundAsset();
                var newSoundchannel:SoundChannel;
                newSoundchannel = sound.play(startTime);
                newSoundchannel.soundTransform.volume = volume;

 SoundAsset and sound are both non-null.  However, newSoundChannel is always null (startTime = 0).  This works in Air, but not on the PB.  How is volume controlled otherwise?

 

Have these issues been addressed before?

 

Thanks!

 

 

 

Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: sound issues?

Assuming you're in 0.9.3 of the simulator.  The sound is broken in this version.  Worked under 0.9.2.

Developer
decibell
Posts: 73
Registered: ‎11-16-2010
My Device: Playbook

Re: sound issues?

yup got the same, has anyone filed a bug for this?

----------------------------
Let's turn things up...
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: sound issues?

No, BB is aware of the issue and they have expanded their testing procedures to include some other test cases.

Developer
decibell
Posts: 73
Registered: ‎11-16-2010
My Device: Playbook

Re: sound issues?

gotcha, I should also mention that streaming audio doesn't work either, whereas sound files do (as opposed to air) in 0.92

----------------------------
Let's turn things up...
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10

Re: sound issues?

I got the impression it had to do with some missing drivers.  Let's hope that we can get an update sooner than a month to resolve this.

Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: sound issues?

 


jtegen wrote:

I got the impression it had to do with some missing drivers.  Let's hope that we can get an update sooner than a month to resolve this.


 

Amen to that!  

 

I don't think it's drivers, though, as the browser can produce sound just fine.  I think it's just one of those silly glitches, probably something last-minute with file permissions, that occur when people rush... and they don't seem to have any adequate regression testing process, in spite of employing 10,000 Waterloo co-op students, who are always the ones assigned to that dreary task. ;-)


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
decibell
Posts: 73
Registered: ‎11-16-2010
My Device: Playbook

Re: sound issues?

Hahaha hey I'm headed there so it can't be all bad :smileywink: Really need that File bug resolved, hopefully they can release a bugfix simulator shortly

----------------------------
Let's turn things up...