Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
tensioncore
Posts: 323
Registered: ‎12-13-2010
My Device: Bold 9900/Z10 Special Edition
Accepted Solution

updating app to 1.1.0 SDK makes it not work

This is a very broad problem, of which I have no indications to what exactly is going wrong.

I recently updated my app using FB 4.5 and AIR 2.6 using the SDK 1.1.0 and the result is odd. The app when unsigned works fine on both the Simulator and my actual device...however once I sign it, when you start the app, it only shows the splash screen and then the screen goes blank with the background color of the app.

Debugging doesn't prove/disprove anything because as I mentioned when its unsigned it works fine...however once signed it doesn't work at all.

Did I miss something between 1.0.1 and 1.1.0?

I'm confused, please assist!
CEO/Lead Developer - Tensioncore™ Design Studios
http://tncr.ws/ - ShortenThis!™ for Blackberry Playbook | ShortenThis!™ for BlackBerry® 10
The Periodical Toe A highly informative Table of Elements
DrawThis! A fun drawing app for the BlackBerry® PlayBook™!
http://www.tensioncore.com/ - Tensioncore™ Web Hosting
Developer
tensioncore
Posts: 323
Registered: ‎12-13-2010
My Device: Bold 9900/Z10 Special Edition

Re: updating app to 1.1.0 SDK makes it not work

Alright. so After some confusion and frustration....I discovered that when I imported my projects into FB 4.5 from Burrito, that for some odd reason my settings for the app build paths and libraries were all different and these issues caused the failure
CEO/Lead Developer - Tensioncore™ Design Studios
http://tncr.ws/ - ShortenThis!™ for Blackberry Playbook | ShortenThis!™ for BlackBerry® 10
The Periodical Toe A highly informative Table of Elements
DrawThis! A fun drawing app for the BlackBerry® PlayBook™!
http://www.tensioncore.com/ - Tensioncore™ Web Hosting