Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Contributor
CatlinFD
Posts: 11
Registered: ‎07-15-2011
My Device: Z10
My Carrier: Telstra

Android 3.0 - 4.0 apps still don't work on Android Runtime 4.2.2

So how is this possible?

 

4.2.2 should mean ALL Android apps below 4.2.2 should work. Yet, a lot still don't work, claiming Error -9 which means the runtime on the device is too old.

 

 

Please use plain text.
Contributor
CatlinFD
Posts: 11
Registered: ‎07-15-2011
My Device: Z10
My Carrier: Telstra

Re: Android 3.0 - 4.0 apps still don't work on Android Runtime 4.2.2

[ Edited ]

I can ensure you that isn't true and I know because I've tried it myself. Try: CNN, Fly Delta, NAB and get back to me.

Please use plain text.
BlackBerry Development Advisor
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: Android 3.0 - 4.0 apps still don't work on Android Runtime 4.2.2

Hey CatlinFD,

 

With the move to Android Jelly 4.2.2, we are able to support applications built on SDK level 17 and below. There are still unsupported items within the Android Runtime. Some of these unsupported items are listed here: https://developer.blackberry.com/android/apisupport/

 

Concerning your error -9, this is specially for unsupported shared libraries. This could be a number of things. I would suggest that you run your application for verification and see what is specifically failing. It could be something like Google Maps, or another unsupported library.

 

Cheers,

Matt

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Please use plain text.