Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Developer
br14
Posts: 497
Registered: ‎06-24-2008
My Device: Not Specified

Android problem

I'm having an issue when I try to run any ported Android app on my Z10 - and now I have the same problem when I've transferred to a Z30.

 

The dark "BlackBerry" page opens, and the blue status bar moves across the base of the screen, but as it reaches half way or so the app closes.

 

Anyone any ideas?

Trusted Contributor
imre_m
Posts: 160
Registered: ‎11-17-2010
My Device: PlayBook, Z10, Q10

Re: Android problem

Try to restart the device and after it has rebooted wait a few more minutes. As I've experienced, the Android Runtime is not fully settled when the home screen appears for the first time.

 

Does your app work in the BB10 simulator?

--
If you find this post useful please Like it.
If it solves your problem please mark as solution.
BlackBerry Development Advisor
bbenninger
Posts: 130
Registered: ‎04-19-2013
My Device: BlackBerry Z10

Re: Android problem

What's the app in question?

Developer
br14
Posts: 497
Registered: ‎06-24-2008
My Device: Not Specified

Re: Android problem

Every Android app I download.

 

In this case, Flipboard, and Ghost Commander.

 

Wiping the device solved the problem but now I have to reload all my contacts, accounts etc