Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
New Developer
vnlakshmi39
Posts: 46
Registered: ‎12-16-2013
My Device: 9780 Bold

Converted bar file is not running on BB10 simulator

Converted apk file to bar file using command line tool and installed on BB10 simulator. My problem is application is not running. Please any one help me on this.

 

Thanks in advance 

New Developer
aafreen
Posts: 10
Registered: ‎09-01-2013
My Device: Z10

Re: Converted bar file is not running on BB10 simulator

Can you specifically tell that which version of simulator you are using

Retired
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10

Re: Converted bar file is not running on BB10 simulator

As a tip, if your application uses native JNI code this would not be supported on the latest BlackBerry 10.2.1 device simulator. You would have to test with a physical device.

 

Does your application use native android code? What version of simulator are you testing with?

 

Cheers,

Matt

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
New Developer
vnlakshmi39
Posts: 46
Registered: ‎12-16-2013
My Device: 9780 Bold

Re: Converted bar file is not running on BB10 simulator

[ Edited ]

I am able to convert using CommandLineTools_2.0.1. Android Native application converted apk is working fine in simulator & device.

My problem is cross-platform application converted apk( like titanium, rhomobile) is not working except phonegap application apk.

Phonegap converted apk is working on simulator 10.2.1 but Xhr calling is not working on device 10.1

Please help on this.

Retired
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10

Re: Converted bar file is not running on BB10 simulator

Hello,

If your application is working on 10.2.1, that's great! We brought in lots of new support in this release and is also likely the reason why it didn't work on a previous version such as 10.1.

As 10.2.1 is the latest and greatest version and being deployed globally, this is all you have to target.

Cheers
Matt
Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators