Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Developer
StevenKader
Posts: 635
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Debugging From Eclipse

Anyone know if it is possible to debug the Android app while it is running on the device.  The app got an error and closed but never stopped in Eclipse.

 

 


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Please use plain text.
New Developer
asgarddesigns
Posts: 4
Registered: ‎02-13-2012
My Device: -
My Carrier: VHA Australia

Re: Debugging From Eclipse

I was debugging fine in Eclipse using the Playbook Simulator.

 

You are using the simulator or an actual device?

Please use plain text.
Developer
StevenKader
Posts: 635
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Debugging From Eclipse

I was trying the actual device. 


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Please use plain text.
New Developer
asgarddesigns
Posts: 4
Registered: ‎02-13-2012
My Device: -
My Carrier: VHA Australia

Re: Debugging From Eclipse

I guess you could try via the simulator and see if you can trigger a breakpoint that way?

Are you seeing any stacktrace?
Please use plain text.
Developer
StevenKader
Posts: 635
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Debugging From Eclipse

I'll try the simulator again.....didn't see the stacktrace. Thanks.

Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Please use plain text.