Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
New Contributor
tjdwowh
Posts: 7
Registered: ‎11-16-2012
My Device: Dev 10 Alpha

Error - Launching App

Using Eclipse to port an Android game.

I am getting an error saying:

 

Error:

 

Exception occured during launch

 

Reason:

Error within Debug UI

 

Details>>

java.lang.reflect.InvocationTargetException

 

I am on Windows 7, 64-bit. I have everything setup properly (ADT 20, signing keys).

I have also tried using a very simple Hello World application too. 

BlackBerry Development Advisor
jdreher
Posts: 82
Registered: ‎11-21-2008
My Device: Z10

Re: Error - Launching App

Which version of eclipse are you running? It may be necessary to run a clean install of eclipse 3.8 as this appears to be an IDE issue.

James Dreher
BlackBerry Development Advisor
New Contributor
tjdwowh
Posts: 7
Registered: ‎11-16-2012
My Device: Dev 10 Alpha

Re: Error - Launching App

I will try that and get back to you.
New Contributor
tjdwowh
Posts: 7
Registered: ‎11-16-2012
My Device: Dev 10 Alpha

Re: Error - Launching App

Still getting the same error.
I noticed that it occurs while the status says:
[2012-11-16 14:54:40 - Jetpack] Packaging project Jetpack

It packages fine when I use BlackBerry tools to Sign for App World, however.
BlackBerry Development Advisor
jdreher
Posts: 82
Registered: ‎11-21-2008
My Device: Z10

Re: Error - Launching App

We'll need more information to be able to determine root cause here. Could you please include the steps to reproduce your issue?

James Dreher
BlackBerry Development Advisor
New Contributor
tjdwowh
Posts: 7
Registered: ‎11-16-2012
My Device: Dev 10 Alpha

Re: Error - Launching App

I added BlackBerry nature, I ran the BlackBerry Tablet OS Deployment Setup Wizard to setup my simulator and my developer keys, and then I simply ran as a BlackBerry Android Application.
New Contributor
tjdwowh
Posts: 7
Registered: ‎11-16-2012
My Device: Dev 10 Alpha

Re: Error - Launching App

I will just use another computer. Thank you for trying to help! :smileyhappy:
BlackBerry Development Advisor
jdreher
Posts: 82
Registered: ‎11-21-2008
My Device: Z10

Re: Error - Launching App

This is likely a connection issue between the simulator/device you are testing on and ADT. Is adb-connect able to communicate with the device, and is it available within the Run Configurations?

James Dreher
BlackBerry Development Advisor