Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Regular Contributor
Posts: 59
Registered: ‎01-08-2009
My Device: Playbook
My Carrier: n/a

Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

[ Edited ]

Isn't the Android Player supposed to be included in the Beta?

Contributor
Posts: 18
Registered: ‎10-25-2011
My Device: Playbook developer
My Carrier: N/A

Re: Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

Do you mean that you upgraded to 2.0, installed Android apps, but they won't run?  If so, that's exactly what I'm seeing too, so consider me a +1 on this issue.

Regular Contributor
Posts: 59
Registered: ‎01-08-2009
My Device: Playbook
My Carrier: n/a

Re: Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

I saw a few youtube videos showing an Android Player app (icon).

 

But I guess we developers really have to test just our apps using the sideload technique. Having said this, I haven't tried it yet as I'm  a Flex developer and hence my apps simply need to be compiled for the Playbook and (side)loaded on to the device using the Flash Builder 4.5.1.

 

So I don't need to sideload any Android apps for testing. I was interested in running all the other Android apps on the market.

New Contributor
Posts: 5
Registered: ‎10-23-2011
My Device: Playbook
My Carrier: T-Mobile

Re: Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

Indeed, I have finally upgraded to 2.0 and I have side loaded apps via the crackberry site of listed apps like kindle, skyfire, etc and they will not load. I loaded them via ddpb. However, I did download the sys.android.bar file by mistake. Any ideas?
Developer
Posts: 123
Registered: ‎03-22-2011
My Device: curve 8900
My Carrier: Rogers

Re: Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

if you've previously installed the Android Player you'll need to wipe your device and install OS 2.0 again. The Android player is now integrated in the OS and runs in the background, so there isn't a player icon.
--
Bitbox
Contributor
Posts: 18
Registered: ‎10-25-2011
My Device: Playbook developer
My Carrier: N/A

Re: Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

I wound up doing a secure wipe and reinstalling 2.0.0 and it seems to work now.  Thanks for your advice, everybody.

New Contributor
Posts: 5
Registered: ‎10-23-2011
My Device: Playbook
My Carrier: T-Mobile

Re: Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

But the wipe doesn't take 2.0 off. Does that matter? Just do the wipe and reinstall bu re-registering?
Highlighted
Contributor
Posts: 18
Registered: ‎10-25-2011
My Device: Playbook developer
My Carrier: N/A

Re: Installed Playbook OS 2.0 Beta for Developers, but the Android Player is missing?

Exactly.  After the wipe, all the applications except the browser were gone, so I had to re-register and reinstall anyway.  Once I did, I could run an Android app.  (I could also connect to WiFi again, which was the other problem that wiping solved.)