Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Developer
Developer
mb1
Posts: 320
Registered: ‎05-26-2009
My Device: Not Specified

Is Android runtime getting deprecated by RIM???

Is Android runtime  getting deprecated by RIM in upcoming BBX release?

 

Its the only development framework missing from "Built For Blackberry" certification eligibility. 

 

http://devblog.blackberry.com/2012/09/built-for-blackberry-and-adobe-air/

Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: Is Android runtime getting deprecated by RIM???

The runtime (as far as any knows) is not being dropped. To be certified, you have to integrate BB services that are not available on Android. The program is "Built for BlackBerry", not "Built for Android that runs on BlackBerry". RIM is encouraging more native built apps using the BB10 SDKs.
Please use plain text.
BlackBerry Development Advisor
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: Is Android runtime getting deprecated by RIM???

Hey,

 

The Andorid Runtime is alive and well in BlackBerry 10! For all the roadmap details, check out https://developer.blackberry.com/android/tools/roadmap/

 

Cheers,

 

 

 

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Please use plain text.
Developer
swayamism
Posts: 101
Registered: ‎10-08-2012
My Device: Non-BlackBerry User
My Carrier: AirTel

Re: Is Android runtime getting deprecated by RIM???

I am an application developer, specializing in Android. But now, I want to start exploring BlackBerry too. However, instead of learning J2ME from scratch, would it be better to just build in Android and port it over to BlackBerry considering that BlackBerry 10 and Playbook supports Android application?

Please use plain text.
Developer
abhi007tyagi
Posts: 225
Registered: ‎09-29-2010
My Device: Limited Edition Z10, Playbook
My Carrier: Airtel

Re: Is Android runtime getting deprecated by RIM???

instead of learning j2me, it would be better to port  apps from Android to BB10 or PB, if you want to use java.

j2me is required for BB7.1 and below. if that's your target then you need j2me.

 

but it would be better if you learn C++/cascades for native BB 10/PB apps or Best option would be Webworks if you want to target all Blackberry Devices and don't require native performance.

 

-Abhinav Tyagi

 

Blackberry Z10-Limited Edition
Blackberry Playbook (won in free playbook offer)
My Apps : pAinT, HealthMeter, Shoot
Please use plain text.