Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
New Contributor
Posts: 4
Registered: ‎01-10-2013
My Device: Bold 9000
My Carrier: Oi

Is Google ADT 21.0.1 Supported?

[ Edited ]

I have ADT 21.0.1 and seems that the eclipse plugin 1.5 does not support this version.

 

Am I right? Any news on that?

 

The problem I face is when I try to launch the app, the console says "Connecting XXX.XXX.XXX.XXX to ADB failed!"

In the emulator an app is open and closed very fast, like just a black screen blink.

 

By the way, I'm using the emulator in safe mode since my graphic card is not supported.

 

Best Regards, 

Plets

New Contributor
Posts: 4
Registered: ‎01-10-2013
My Device: Bold 9000
My Carrier: Oi

Re: Is Google ADT 21.0.1 Supported?

I just realized that my app is using API 7 and not 10. Do I need to change it to specificaly use 10 or 7 should be OK?
Developer
Posts: 1,305
Registered: ‎01-21-2009
My Device: Not Specified

Re: Is Google ADT 21.0.1 Supported?

I'm usng the 1.5 plugin with ADT 21.0.1 with no problem. You definitely need to set your project to use API 10, although I don't know if that explains the error you are seeing.




Solved? click "Accept as solution". Helpful? give kudos by clicking on the star.
Highlighted
New Contributor
Posts: 4
Registered: ‎01-10-2013
My Device: Bold 9000
My Carrier: Oi

Re: Is Google ADT 21.0.1 Supported?

[ Edited ]

With the BlackBerry10Simulator-BB10_0_09 I could not load Android apps. 

 

Then I installed and tried it with BlackBerryPlayBookSimulator-2.1.0 and it`s working there.

Unfortunately is not exactly what I want, because I`m developing smartphone targeted apps but for testing purpose it will work.

 

If I get news about the issue I update it here.