Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
BlackBerry Development Advisor
jjasmann
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B
My Carrier: Bell

Re: MinSDK required level 10 for JellyBean runtime

Are you deploying to the simulator by any chance? The simulator doesn't currently support Jelly Bean.

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
Please use plain text.
New Developer
secbbm
Posts: 9
Registered: ‎06-23-2013
My Device: BB Z10
My Carrier: STC

Re: MinSDK required level 10 for JellyBean runtime

 

Then what is the solution. How do I check this. Because for me I have the same error. How do I test the converted application. I have a simulator BB10_2_0X.330. Even on it it doesn't run. It deploys the app, but when I run it crashes without any error on the simulator.

 

Please use plain text.
BlackBerry Development Advisor
jjasmann
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B
My Carrier: Bell

Re: MinSDK required level 10 for JellyBean runtime

Right, that is because the simulator doesn't presently have the 4.x runtime.

 

If you don't have a physical device that is running the 10.2 OS build, you'll need to wait until the simulator is updated with the Jelly Bean runtime.

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
Please use plain text.
New Developer
secbbm
Posts: 9
Registered: ‎06-23-2013
My Device: BB Z10
My Carrier: STC

Re: MinSDK required level 10 for JellyBean runtime

I have a Z10, but it has 10.1 as the last update. And it says that this is the latest update for me.

And a Simulator BB10_2_0X.339 which is 10.2. But why it doesnt have the jelly bean runtime. because 10.2 was suppose to come with the jelly bean. Can i install it manually on the simulator.

 

So till when should i expect the jelly bean runtime to be updated. Is there a time frame.

 

Please use plain text.
BlackBerry Development Advisor
jjasmann
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B
My Carrier: Bell

Re: MinSDK required level 10 for JellyBean runtime

Oh that's great! I didn't reaize you had a device.

 

If you want, you can install the 10.2 beta using the Autoloader for your specific device model, and test it that way.

 

I don't believe we have a timeline out on the simulator, but it should be very soon.

 

:smileyhappy:

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
Please use plain text.