Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
New Contributor
mendozamiche
Posts: 7
Registered: ‎03-12-2014
My Device: Z10

SESSION_ALREADY_EXISTS

I have a question about the SESSION_ALREADY_EXISTS error in my original app. I realized this is probably due to me installing an Android port that uses the same credentials as our original webworks app. 
 
Now that I've uninstalled both apps, restarted the phone then reinstalled our original app, the original app (webworks app) keeps giving that error.
 
What is the solution for this so we can get our old app working again with push?
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: SESSION_ALREADY_EXISTS

The only time I've seen that error is when another app on the device has the same credentials registered with the device, but you've already deleted the app and restarted which should clear that registration. It sounds like the registration could be lingering. 

 

If this happens again could you try destroying the channel from the WebWorks app before deleting the app and restarting? That may help flush out the registration.

Garett
@garettBeuk
--
Goodbye everybody!
New Contributor
mendozamiche
Posts: 7
Registered: ‎03-12-2014
My Device: Z10

Re: SESSION_ALREADY_EXISTS

I'm unable to destroy the channel since the app is unable to create the Push Service object in the first place. It seems the only other way to fix this is to reset the BB10 device to factory default settings.

Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: SESSION_ALREADY_EXISTS

Very strange...

 

If this happens again please let me know, I'll grab logs and file a bug.

Garett
@garettBeuk
--
Goodbye everybody!