Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Developer
StevenKader
Posts: 645
Registered: ‎02-03-2010
My Device: Z10 LE

Signing problem with Eclipse on OSX

Trying to sign an Android project on Eclipse in OSX.  Getting "Invalid Tools SDK" in problems section after building/signing runs.  Anyone seen this.  I checked and have BB SDK 1.3  and Android tools V20 installed   APK is fine because command line tools work after. 


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Retired
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10

Re: Signing problem with Eclipse on OSX

Hey Steven,

 

When you see this popup in the Problems section, was your application signed? That is, everything appears to work, but you are just seeing that error listed?

 

 

 

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Developer
StevenKader
Posts: 645
Registered: ‎02-03-2010
My Device: Z10 LE

Re: Signing problem with Eclipse on OSX

Hi Matt,

 

I don't see any BAR file in a 'dist' directory.  I assume it would be in the project directory....don't see it.

 

Steve


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Developer
StevenKader
Posts: 645
Registered: ‎02-03-2010
My Device: Z10 LE

Re: Signing problem with Eclipse on OSX

Here is some pics of my setup that may help.   Thanks.android-sdk.jpgBB-sdk.jpg


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Retired
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10

Re: Signing problem with Eclipse on OSX

Hmm, pictures don't seem to load.

 

Have you tried increasing your app version number, and try signing again? Regarding the "Invalid SDK Tools" message, I'll take this back to the dev team to get logged and looked at.

 

Thanks,

 

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Developer
StevenKader
Posts: 645
Registered: ‎02-03-2010
My Device: Z10 LE

Re: Signing problem with Eclipse on OSX

Tried that...no luck.  I'll email you the pics.

 

 


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
New Contributor
erichcervantez
Posts: 3
Registered: ‎11-12-2012
My Device: Playbook

Re: Signing problem with Eclipse on OSX

I had the exact same problem. Turns out I had the BETA BlackBerry Tools SDK installed. I had to install the BETA in order to solve a known bug with compiling out to my Playbook under the 20.0.3 revision of Android SDK Tools (which it appears is also what you have).

Once I uninstalled the BETA and re-installed the latest non-beta version of BlackBerry's SDK Tools, the error went away.