Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Contributor
doomsknight
Posts: 33
Registered: ‎03-13-2012
My Device: 9860
My Carrier: 1234

Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

 

Your application uses a feature which is incompatible with the current version of the BlackBerry® Runtime for Android™ Apps. We recommend that you download the BlackBerry® Plug-in for ADT to test your application and remove features as required.

 

4. Severe incompatibilities found

 

ImpactTypeReason
2uses-featureandroid.hardware.camera.autofocus

 

Now, I removed the line from the mainfest. But still the same problem.

 

I know that     <uses-permission android:name="android.permission.CAMERA"/> implies use of autofocus?..

 

But I cant just remove the camera feature from my app. Surely BB supports androids desire to use a camera.

Please use plain text.
BlackBerry Development Advisor
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

Hello,

 

If you package your application with our Command Line tools or Eclipse Plug-in, would will be able to bypass this warning/error and test your applications on a device or simulator. Your application should work just fine as we support the camera, but just not autofocusing.

 

You can grab the tools here: http://developer.blackberry.com/android/tools/

 

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Please use plain text.
Contributor
doomsknight
Posts: 33
Registered: ‎03-13-2012
My Device: 9860
My Carrier: 1234

Re: Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

[ Edited ]

Thanks for the reply.

 

I removed the requires camera, for testing the rest of it.

 

So I recieved my .bar file. But I have no idea how to get this onto a virtual playbook.

 

There was some comandline that came up a few times, 

blackberry-deploy .... Something something

 

But requires access to the SDK. Now, I could never succesfully locate this. I check inside the eclipse folder for example, where the SDK is installed? But it would never recognise the blackberry as a valid function, command line option or whatever.

 

On expansion to the Tools.

I installed the eclipse plugin but when it came to installing:

The addon called "Blackberry Plug-in for android Development Tools"

 

I keep getting :

Cannot complete the install because of a conflicting dependency.
  Software being installed: BlackBerry Plug-in for Android Development Tools 1.5.0.201211282047 (net.rim.ajde.feature.feature.group 1.5.0.201211282047)
  Software currently installed: Android Development Tools 20.0.3.v201208082019-427395 (com.android.ide.eclipse.adt.feature.group 20.0.3.v201208082019-427395)
  Only one of the following can be installed at once: 
    Android Development Tools 20.0.3.v201208082019-427395 (com.android.ide.eclipse.adt.feature.jar 20.0.3.v201208082019-427395)
    Android Development Tools 21.0.0.v201210310015-519525 (com.android.ide.eclipse.adt.feature.jar 21.0.0.v201210310015-519525)
  Cannot satisfy dependency:
    From: Android Development Tools 20.0.3.v201208082019-427395 (com.android.ide.eclipse.adt.feature.group 20.0.3.v201208082019-427395)
    To: com.android.ide.eclipse.adt.feature.jar [20.0.3.v201208082019-427395]
  Cannot satisfy dependency:
    From: Android Development Tools 21.0.0.v201210310015-519525 (com.android.ide.eclipse.adt.feature.group 21.0.0.v201210310015-519525)
    To: com.android.ide.eclipse.adt.feature.jar [21.0.0.v201210310015-519525]
  Cannot satisfy dependency:
    From: BlackBerry Plug-in for Android Development Tools 1.5.0.201211282047 (net.rim.ajde.feature.feature.group 1.5.0.201211282047)
    To: com.android.ide.eclipse.adt.feature.group 21.0.0

 

Please use plain text.
BlackBerry Development Advisor
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

You can use the Command Line tools to deploy your applicaiton to the simulator.

 

Once you download the lastest tools (v 1.5), you can use this guide for all the instructions: http://developer.blackberry.com/android/documentation/preparing_android_apps_for_bbtos_2016812_11.ht...

 

Cheers,

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Please use plain text.
Contributor
doomsknight
Posts: 33
Registered: ‎03-13-2012
My Device: 9860
My Carrier: 1234

Re: Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

Please see expansion to my reply. Thanks.
Please use plain text.
BlackBerry Development Advisor
mwhiteman
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

Okay, so that is your Eclipse Environment. Did you setup a new enivorment or are you updating an old you?

 

Assuming you have a new install of Eclipse, if you go to the "Install new software" click in the help menu, you should be able to point Eclipse to:http://bdsc.webapps.blackberry.com/android/downloads/eclipseplugin/

 

This will install both the BlackBerry Plug-in and ADT21. We'll still need to download and install the Android SDK seperately. The steps to get everything for Eclipse can be found here: http://developer.blackberry.com/android/documentation/install_plugin_prerequisites_2016780_11.html

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Please use plain text.
Contributor
doomsknight
Posts: 33
Registered: ‎03-13-2012
My Device: 9860
My Carrier: 1234

Re: Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

This is updating my android eclipse.

 

By adding the blackberry plugins to it. I have Android SDK 10, the ADT etc.

 

Thats the link I point to, (and the instruction page I followed) and I click the options in the list (2 of them).

 

But the one fails due to dependancies.

 

I will try a fresh eclipse environment when I get time.

 

Thanks.

Please use plain text.
Trusted Contributor
MXZ
Posts: 104
Registered: ‎11-28-2012
My Device: PlayBook
My Carrier: 3 it

Re: Your application is not compatible with the BlackBerry® Runtime for Android™ Apps.

You can select what feature you use and don't use in android manifest
Please use plain text.