Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Retired
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: untrue - uses-library: android.test.runner

Thanks for the dump, now I see where the confusion comes from.

 

You are using unsupported library 'com.google.android.maps' which triggers verifier to log a warning.

However there is a bug in the verifier pointing to the only supported library 'android.test.runner' in the text instead of the found 'com.google.android.maps'.

 

Again thanks for the report and we have logged this issue.

 

Cheers,

Matt

 

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Highlighted
New Contributor
Posts: 9
Registered: ‎07-27-2012
My Device: Z10 LE, 9900, Playbook, Dev Alpha
My Carrier: Orange

Re: untrue - uses-library: android.test.runner

Try to remove the maps library, google maps are not supported for Android aplicacions
Contributor
Posts: 11
Registered: ‎07-15-2011
My Device: Z10
My Carrier: Telstra

Re: untrue - uses-library: android.test.runner

Matt, the issue has not been fixed yet?

Retired
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: untrue - uses-library: android.test.runner

Hello CatlinFD,

 

This issue is now fixed in the 1.6 version tooling release. The online package will be updated soon to include these updates. Please let me know if you are still experiencing issues.

 

Cheers,

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators
Retired
Posts: 5
Registered: ‎02-13-2013
My Device: Q10
My Carrier: O2 CZ

Re: untrue - uses-library: android.test.runner

According to you AndroidManifest dump you are using:

uses-library:'com.google.android.maps'

There has been a bug fixed in our tools which cause confusion by listing wrong library name. It is already fixed in our recent release and you will see following warning message instead:

(AndroidManifest.xml) uses-library: com.google.android.maps:impact=4