Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Runtime Development

Reply
Developer
Posts: 672
Registered: ‎12-04-2012
My Device: BlackBerry 8520
Accepted Solution

when I tried to run my ported Application with "BlackBerry Android Launch" on Bb 10.2 simulator Error:ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde code=0

ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde

 

 

code=0 Please check if the Android player was fully started when you got this error. If not, you can either

 

increase the Android player launch timeout on the BlackBerry->BlackBerry Android Development Tools

 

preference page or wait until the Android player is fully started and try again. null].

 

 

Please guide me How to fix this issue where do I find  

 

BlackBerry->BlackBerry Android Development Tools

 

 

Please guide me with Exact Path

 

Thanks

Retired
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B

Re: when I tried to run my ported Application with "BlackBerry Android Launch" on Bb 10.2 simulator Error:ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde code=0

Hey srk2012,

 

It looks to me like either the Android Player didn't start up correctly on the simulator, or ADB is not running on your machine. Would you mind posting which version of the simulator you're attempting to deploy to?

 

I'm not sure what you're referencing with BlackBerry -> BlackBerry Android Development Tools, but here are a few suggestions:

 

1. The microsite address for the development tools is here : https://developer.blackberry.com/android/tools/

2. In Eclipse, there is a "BlackBerry Tools" option if you right-click on your project (presuming you've added the Eclipse Plug-in for BlackBerry Development (https://developer.blackberry.com/android/documentation/install_plugin_prerequisites_1895476_11.html)

3. In Eclipse, if you go to Window -> Preferences, there is a preference for "Blackberry"

 

Hope this helps!

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
Developer
Posts: 672
Registered: ‎12-04-2012
My Device: BlackBerry 8520

Re: when I tried to run my ported Application with "BlackBerry Android Launch" on Bb 10.2 simulator Error:ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde code=0

I have chosen the third option and followed

 

 

In eclipse Window -> preferences -> 

 

BlackBerry->BlackBerry Android Launch Timeout and incresed it to   800000000  ms.

 

But Now Iam seeing the error

 

 

[2013-10-31 14:55:39] Connecting 192.168.48.130 to ADB...
[2013-10-31 14:55:39] AP shell finished...
[2013-10-31 14:55:40] AP shell started: unable to connect to 192.168.48.130:5555

[2013-10-31 14:55:43] Connecting 192.168.48.130 to ADB...
[2013-10-31 14:55:43] AP shell finished...
[2013-10-31 14:55:44] AP shell started: unable to connect to 192.168.48.130:5555

 

 

Shall I uninstall thes imulator and start the new one  

Retired
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B

Re: when I tried to run my ported Application with "BlackBerry Android Launch" on Bb 10.2 simulator Error:ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde code=0

srk2012,

 

Which simulator version are you using? Is that IP the correct address for that virtual machine?

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
Developer
Posts: 137
Registered: ‎07-24-2012
My Device: Blackberry Z10 LE, Q10 And PlayBook

Re: when I tried to run my ported Application with "BlackBerry Android Launch" on Bb 10.2 simulator Error:ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde code=0

Dude, it looks like you have not enabled the development mode in your emulator, I recommended you to enable it 1st and you can start.... the ip address after enable the development mode will be 169.254.0.1
Hit Like if you find my post Use Full Thank You...
Developer
Posts: 672
Registered: ‎12-04-2012
My Device: BlackBerry 8520

Re: when I tried to run my ported Application with "BlackBerry Android Launch" on Bb 10.2 simulator Error:ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde code=0

Yes my simultor is lareday in dvelopement mode but during configuration of targets with auto discover of devices.

 

 

The IP Address it is hwoing is   192.168.48.130.

 

 

Earlier it used to work Iam able to run the app with same ip on the simulator.

 

 

Developer
Posts: 672
Registered: ‎12-04-2012
My Device: BlackBerry 8520

Re: when I tried to run my ported Application with "BlackBerry Android Launch" on Bb 10.2 simulator Error:ERROR: net.rim.ajde code=4 Connecting 192.168.48.130 to ADB failed! null children=[Status ERROR: net.rim.ajde code=0

Ok I have  Un installed and  Installed the new one freshly.

 

My problem got solved . Please respond  to my other query

 

 

about loading BAR file on BlackBerry Q5 please.

 

http://supportforums.blackberry.com/t5/Android-Runtime-Development/How-to-load-a-signed-BAR-on-the-R...