Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Contributor
bblacksheep
Posts: 32
Registered: ‎10-28-2012
My Device: Z10, PB WiFi, Bold 9900

Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

Hi,

A couple of our users are experiencing serious delays in email delivery on their BDS-controlled Z10s while roaming. With "serious" I mean delays in the magnitude of hours. This is something however that purely relates to Z10 and the way message sync is done (activesync)

 

Since we've got both legacy (OS7) devices and BB10-devices on our network I can confirm that email delivery on the legacy devices happens instantly while BB10-devices experience the above mentioned delays when roaming.

 

So here are my questions:

 

  • Anybody else experiencing this problem (I saw a post under BB10 automatic sync not working while roaming in US mentioning US roaming problems, but in our case it's Europe and travelling between European countries)

  • Is there a way to get an activesync-log from the Z10s itself showing dates/times of activesync and error-messages respectively? (Afaik the phone has an end-to-end-connection to the activesync/exchange server) - on other platforms (IOS, Androids) you can find a local activesync log on the smartphone so I'm positive that something like this must be present on BB10 too.

  • Any known cure - or at least an idea how to track this down?

Thanks much in advance for any clue

-bblacksheep

New Contributor
QTSFR
Posts: 3
Registered: ‎05-20-2013
My Device: Q10

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

I am having the exact same problem. Blackberry Q10, home operator SFR France. Since yesterday (27 May 2013) I am roaming in Switzerland and my emails are not being pushed.

 

About a week ago I made my first roaming trip, from France to UK, and had a different problem, which I discussed here:

 

http://supportforums.blackberry.com/t5/General-BlackBerry-10-Smartphone/BB10-automatic-sync-not-work...

 

(Push was not working -- turns out my Exchange Server was not configured correctly -- I contacted my Exchange Server administrator to allow PUSH when ROAMING. Here are Microsoft's instructions:

 

http://technet.microsoft.com/en-us/library/bb123994(v=exchg.141).aspx

 

See Point 6:

 

Allow Direct Push when roaming   Select this check box to enable the mobile phone to synchronize as new items arrive when you're  roaming with your phone.)

 

Well, now, a week later, I am roaming again, and even though I have my server configured for push when roaming, the emails are not getting pushed! The same emails arrive on my wifi-connected laptop right away. Sometimes the delay of these same emails getting pushed to the BlackBerry is 10-20 minutes; sometimes it is an hour or more. I am missing out on important on-the-fly discussions and I had to re-check-in for a flight using my iPhone because I did not receive a boarding pass in time on my Q10.

 

Another UK user is reporting similar issues, on CrackBerry:

 

http://forums.crackberry.com/blackberry-10-os-f269/z10-microsoft-exchange-activesync-email-delays-80...

 

He said:

 

"...huge delays when I don't receive anything on my phone for a few hours and then suddenly I've got a whole bunch of email time-stamped in the interval of those past few hours. Then after some time push stops working completely - even when I try to manually refresh emails on my Z10 it does nothing until I re-setup the exchange account."

 

I am having what appears to be the same problem.

 

This problem of long delays in email being pushed to the BlackBerry 10 is extremely serious. I was expecting an almost seamless transition to BlackBerry 10. Clearly there are significant bugs that need to be fixed or explained urgently. BlackBerry's reputation for reliability and ease-of-use is going to suffer serious damage if this problem continues!

Hall of Famer II
sdgardne
Posts: 48,794
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

I don't know if my situation is related or not, but I have (since Friday) been experiencing delays with Gmail on my Z10. However, it's not universal. I have 9 Gmail accounts, and only a subset are affected by delays, while others receive everything immediately. They are all integrated via ActiveSync, and delivery elsewhere (e.g., Outlook client, Gmail webmail inteface) is not affected.

If the problem affected all of my Gmail accounts the same, I might believe that the problem is with BB or my carrier services. But, since it's only affecting a subset, I instead believe my issues to be rooted at Google. Given all they have recently done to alienate the BB platform, I'm actually not terribly surprised either.

Note that no roaming is involved...this is on home network carrier and also almost completely on WiFi. No changes have been made to the configuration...but this behavior started suddenly on Friday. Eventually, everything gets delivered and reconciled...but on some accounts, the delay is quite large.

If your issues can be narrowed down so as to truly know a root cause, and that root cause results in being something in the BB device, OS, or infrastructure, then you need to contact your mobile service provider for formal support and potential escalation up to BlackBerry for enhanced support.

Good luck!

Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
markusc
Posts: 22
Registered: ‎05-30-2013
My Device: Q10

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

I just purchased a Q10 and love the device, but the email is driving me crazy. It works great and fast sometimes and then at some point in the day there's a 10-20 minute delay with emails. I have Exchange Server in my office so is this an exchange issue or blackberry push issue?

Hall of Famer II
sdgardne
Posts: 48,794
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?


markusc wrote:

I just purchased a Q10 and love the device, but the email is driving me crazy. It works great and fast sometimes and then at some point in the day there's a 10-20 minute delay with emails. I have Exchange Server in my office so is this an exchange issue or blackberry push issue?


Hello,

 

If this affects only that one account, then you definitely need to work with your internal system admins. They may want further assistance from others, but they definitely need to be involved.

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
markusc
Posts: 22
Registered: ‎05-30-2013
My Device: Q10

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

Thank you. When you say "they" you mean my internal IT or Blackberry?

New Contributor
QTSFR
Posts: 3
Registered: ‎05-20-2013
My Device: Q10

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

markusc: Is this happening when you are roaming? Or is it a problem on your home network? Have you asked your Exchange Server administrator to enable PUSH WHEN ROAMING? The default is NOT to allow push when roaming. Are you sure all your device settings are for PUSH?

 

Personally the problem of erratic delays in receiving e-mails is only when I am roaming.

Hall of Famer II
sdgardne
Posts: 48,794
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

[ Edited ]

markusc wrote:

Thank you. When you say "they" you mean my internal IT or Blackberry?



Your internal IT is who I mean by "they". If your internal IT needs additional help, then your internal IT can seek it out...but your internal IT definitely needs to be involved in your situation.


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
markusc
Posts: 22
Registered: ‎05-30-2013
My Device: Q10

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

I'm at home on Att network so not sure if that is roaming or not.

I will look at the iT person to get some feedback

Contributor
markusc
Posts: 22
Registered: ‎05-30-2013
My Device: Q10

Re: Activesync - long delays in email delivery while roaming / local activesync log on BB10-device?

Thank you