Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Member
Posts: 1
Registered: ‎06-01-2013
My Device: Q10
My Carrier: Vodafone

Blackberry logo on screen - and nothing more!

Hi All,

 

Got my Q10 yesterday from work - I set it up and all was fine.

 

I have been charging all night, however when I try to turn on, I get the purple blackberry image that works it's way up to 100%, however, I can't get the phone to do anything when I have the blackberry logo on screen. If I touch the image it just say's 100%.

 

Bizarelly, when I charged all last night (with the new charger provided) it had an empty battery sign, and then a 'lighting' bolt image.

 

It's driving me nuts - just want to be able to use it. I have taken the battery out and in again, but this hasn't resolved it.

 

Anythiing you can suggest to help would be most welcome.

 

Thanks very mcuh in advance!

 

Elite II
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30
My Carrier: Rogers

Re: Blackberry logo on screen - and nothing more!

If I understand correctly, the BlackBerry logo appears as your phone is rebooting but then remains at 100% with nothing happening after that.

If that's the case, try plugging your phone in to your PC and opening BlackBerry Link.  You might need an OS reload and Link will help you with that.

 

 

Give that a try and post back with your results.  Smiley Happy


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.