Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
deryo
Posts: 2
Registered: ‎03-29-2013
My Device: BlackBerry Z10 STL100-2

Sending emails by SMTP over submission port (587) with TLS fails (qmail)

 

Hi there.

 

I have problems sending emails with Blackberry 10 (10.0.10.90).

 

My setup:

username: mail@server.tld

password: ****

smtp server: server.tld

smtp port: 587

encryption: StartTLS

 

I use the same settings on my Nokia N900, Samsung Galaxy Tab, Windows 8 Pro, Opera M2 and everything works fine with them. All devices are on the same network. When I hit "save" on the account settings with my Z10 it sais they get veryfied and saved.

 

The problem arises when I try to send an email. At first it becomes the icon for 'being sent', after that a clock icon for 'delayed' and after some time (hours?) a no entry sing for 'failure'. When I open up the account settings it says that the server is currently not available.

 

I am absolutely sure the settings are correct. I tried every combination of the ports 25, 465, 587 and encryption methods. The server does not offer SSL (port 465) and only accepts TLS-encrypted sessions 587 (submission port) with login or non-relaying emails on port 25 without login. The only setting giving me no error at configuration time is the correct one (587 with login and TLS).

 

As I happen to own the mail server I can have a look at the logs. When trying to send an email it shows this:

Mar 29 13:50:48 core cmd5checkpw: SMTP connect from xxx [xxx.xxx.xxx.xxx]
Mar 29 13:50:48 core cmd5checkpw: SMTP user mail@server.tld: logged in from xxx [xxx.xxx.xxx.xxx]
Mar 29 13:50:49 core qmail-queue-handlers[11249]: Handlers Filter before-queue for qmail started ...
Mar 29 13:50:49 core qmail-queue-handlers[11249]: possibly qmail-smtpd exited by timeout, reset connection. #011#011#011#011    See "http://pobox.com/~djb/docs/smtplf.html." for get more information.

 

The link says it seems Blackberry OS' email client sends a bare LF. This seems to be a bug. Where do I have to report this?

 

Best wishes,

DerYo-->

 

 

 

Contributor
catharsis3k
Posts: 13
Registered: ‎11-24-2008
My Device: Not Specified

Re: Sending emails by SMTP over submission port (587) with TLS fails (qmail)

I can confirm this is indeed an issue. Huge oversight from the company that focused on e-mail to let such a bug slip in