Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 OS Device Software

Reply
New Contributor
bob22red
Posts: 9
Registered: ‎01-29-2014
My Device: Z10
My Carrier: O2

Re: Bluetooth issues after 10.2.1 update

Still unable to get Bluetooth to work with Mercedes in-car system. All my previous Blackberry 'phones and my wife's iphone work without difficulty. It's juts the brand new Z10 with software release 10.2.1.537 which will not connect and as a result is next to useless when I am driving. From other posts it seems that Blackberry are aware of the problem so surely by now they could have come-up with a fix for this most basic of functions - after all in a car it is a safety issue.

Please use plain text.
New Contributor
Sandyp
Posts: 4
Registered: ‎04-13-2013
My Device: BlackBerry z10
My Carrier: Bouygues telecom

Re: Bluetooth issues after 10.2.1 update

My problem still persists:

- BBRY Z10 OS 10.2.1.537
 with Mercedes.

French BBRY assistance told me that I have to return to the previous version of the OS or wait for a new realease.... I do not know if they are really aware of that issue, and if they considering it...

Please use plain text.
Contributor
stumcqueen
Posts: 29
Registered: ‎02-11-2013
My Device: Blackberry Z10
My Carrier: EE

Re: Bluetooth issues after 10.2.1 update

Bob22red

 

I had the same issue when my z10 updated to 10.2.1.537

 

It is however now connecting to my mercedes as it once did. It did take some faffing about to achieve it though. There are several steps to try. I'll list them here.

 

Fist Option:

Remove all pairings from your Phone and Mercedes.

Pair the devices again (with mine the initial pairing always worked but would not reconnect again after that).

Once paired on the phone in bluetooth settings press and hold the MB Bluetooth device, an options bar comes in from the right. Select the top option device properties. You should see an option for Hands Free Calling. Make sure it is set to On. If you only see the device address chances are it wil not reconnect and you have more work to do.

 

Second Option:

Take a bakc up of your data and do a full security wipe. Be advised depending on how much data you have on your phone it could take some time. Mine took 2 hours.

Reload the device software using BB Link.

In your car, remove all the pairings.

Go into the Engineering Menu on the Command System, accessed by pressing the 6, *, and End Call button simultaneously and holding until the eng menu comes up.

Go into applications/bluetooth

Reset bluetooth system

Deauthorise Pairings

Reactivate Bluetooth System.

Come out of Engineering Mode and Pair phone as before.

 

After doing all that mine started working properly.

 

From what I understand sometimes the update does not give a clean install of the OS. I know its a pain but it thats how I got mine working again.

 

Hope this helps.

 

PS BlackBerry Helpdesk were less than helpful

Please use plain text.
New Contributor
Sandyp
Posts: 4
Registered: ‎04-13-2013
My Device: BlackBerry z10
My Carrier: Bouygues telecom

Re: Bluetooth issues after 10.2.1 update

Many thanks.

I will try option2 even if im tired to reinstall this OS and reset my phone!

 

I know that option1 cannot be fine because i dont have the hand free calling option when I click on Details (only the name of the MB device and the adress appaers)

Please use plain text.
Contributor
aboxoflogic
Posts: 17
Registered: ‎06-16-2009
My Device: Not Specified

Re: Bluetooth issues after 10.2.1 update

OK I have a 2011 CLS 550 that has worked previously with 10.1.x version via Bluetooth.   I did the update to various 10.2 leaks and had to downgrade when they wouldn't connect to my car.  Now Verizon has released their official 10.2.1 update and I performed it.   The phone still won't connect to the car.   I have tried everything on every forum and I can get a successful pairing if I delete the phone from the car and the car from the phone and add the phone to the car anew - I give a passcode to the car and then the same one to the phone and it will connect.  If I look at the details on the MB Bluetooth I do not have the handsfree option - only the name and the bluetooth address.   As soon as I either turn off the car or turn off the bluetooth on the phone it stops working.  And if I repeat the delete car from phone, phone from car I can get it to connect again.   When it is connected I do see the MB logo and "handsfree" calling but again the option isn't there under the bluetooth.  I feel like the issue is somewhere once I set the car to be a Mercedes.   One time I tried by tell it to let me choose my car later and when I did this I would get a constant flash of that "select your car" screen that would come up and disappear before being able to click on anything.   Then I did the delete from both again, connected fine and then lost it upon engine off.   I have tried various things like a full restore of the OS, renaming the phone, connecting via the External Authorization vs the Find Bluetooth Devices option.   I think it is notable that besides not having the Hands Free Calling option that the car does see the phone under the Settings --> Bluetooth.  It shows my phone's name and a little check mark like it is currently connected.   But then when I go over to the Phone menu it doesn't show my phone and says "Ready for Authorization" (as if there is no phone).   Anyone else see exactly what I am and has anyone figure out how to get the Hands Free option to show up?  Thanks to you all!

Please use plain text.
New Contributor
marclinett
Posts: 8
Registered: ‎01-31-2014
My Device: Q10
My Carrier: Rogers

Re: Bluetooth issues after 10.2.1 update

It definitely is a BB issue. Took my car in to Mercedes and they said the same thing. Awaiting BB to fix the problem. How long it will take is of concern. Never should have upgraded to 10.2 so quickly.
Please use plain text.
Contributor
stumcqueen
Posts: 29
Registered: ‎02-11-2013
My Device: Blackberry Z10
My Carrier: EE

Re: Bluetooth issues after 10.2.1 update

Aboxoflogic

 

I had the exact same problems on my 2010 CLS500. It is however now working.

 

In order to get it working, I had to do a full security wipe of the handset which took about two hours.

 

Once my device was fully reset, I reset all the bluetooth services in My MB. YOu need to access the hidden engineering menu for this on the COMMAND system. mine was accessed by holding down end call 6 and * at the same time.

 

I reset bluetooth devices, reset bluetooth system and reactivated.

 

When I paired the device again the handsfree option was showing on the device settings.

 

Blackberry Technical support were completely useless and referred me back to MB.

 

I understand that there are lots of gremlins that lurk in the OS when it has been updated several times. It's possible the security wipe flushed these out.

 

Hope that helps.

 

Stuart

Please use plain text.
Contributor
stumcqueen
Posts: 29
Registered: ‎02-11-2013
My Device: Blackberry Z10
My Carrier: EE

Re: Bluetooth issues after 10.2.1 update

I was running 10.2.0 and it worked fine, it was the 10.2.1.537 that caused me all the issues.

 

Just posted how I got mine working

Please use plain text.
New Contributor
Sandyp
Posts: 4
Registered: ‎04-13-2013
My Device: BlackBerry z10
My Carrier: Bouygues telecom

Re: Bluetooth issues after 10.2.1 update

I dont know How it's possible but it finally works (z10 os 10.2.1.537 and Mercedes)
I did nothing but it seems to work since i ve connected my phone with my laptop and only make a save of my phone with Bbry Link. I did nothing else special with my mercedes system or bbry system. So strange! Hope you will be as Lucky as me!
Please use plain text.
Contributor
aboxoflogic
Posts: 17
Registered: ‎06-16-2009
My Device: Not Specified

Re: Bluetooth issues after 10.2.1 update

I saw your earlier suggestion of the End Call/6/* Engineering option but I couldn't get my car to display it.   I pressed them all together and tried variations of pressing them in a variety of screens (phone vs settings, etc) but with no luck.   I agree with everything you say but reformatting the phone can't be done in this moment (long story).

Please use plain text.