Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 OS Device Software

Reply
New Contributor
Posts: 4
Registered: ‎11-07-2013
My Device: Z10

IMAP Failure since upgrading to 10.2

[ Edited ]

Hi all,

 

I have used my Z10 against my own IMAP server (Dovecot 1.2) for a while and it has always worked fine. Until I upgraded to 10.2 yesterday (10.2.0.424), when it just stop working on the BB displaying the "An unexpected problem occured with.... Some features may not be working correctly" message.

 

I have seen a few similar reports here but no definitive explanation it seems.

 

Investing a bit more, I configured the server to accept connection in the clear and looked at the data on the wire, it seems the BB is shuting down the connection immediately after having received the capabilities:

 

* OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE STARTTLS LOGINDISABLED] Dovecot ready.
HCLM1 CAPABILITY
* CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS MULTIAPPEND UNSELECT IDLE CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS STARTTLS LOGINDISABLED
HCLM1 OK Capability completed.
HCLM2 LOGOUT
* BYE Logging out
HCLM2 OK Logout completed.

 

Looks like a bug in the IMAP client, has anybody got any info?

 

(I'm in the UK on 02, but am connecting via wifi for testing purposes)

 

Nic

New Member
Posts: 1
Registered: ‎11-09-2013
My Device: Z10

Re: IMAP Failure since upgrading to 10.2

[ Edited ]

I have the same problem Z10. O2 UK. I'm trying to access a Hostpapa (UK ISP) account over IMAP. I also use Gmail on the device over IMAP and it's working fine. Tested over wifi and mobile data. Have tried deleting the account and recreating it. Have tried rebooting. It worked fine until the 10.2 update. The error message I get is "Unexpected problem".

New Contributor
Posts: 4
Registered: ‎11-07-2013
My Device: Z10

Re: IMAP Failure since upgrading to 10.2

I have fixed the problem by upgrading my server from Dovecot 1.2 to version 2.1. Amongst other changes, the new version support COMPRESS=DEFLATE compression which might the reason why it failed on the 10.2 client.

 

Obviously, if you don't own the server, this is not a practical solution but maybe can you ask the ISP which server they use and suggest upgrading?

 

Ideally though, it's up to BB to fix their client really.