Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 OS Device Software

Reply
New Contributor
Posts: 2
Registered: ‎02-12-2013
My Device: Z10
My Carrier: Orange UK

Z10 Keyboard problems

I've started having problems with my keyboard like they're sticking. It seems to be getting worse, and simulates me keeping my finger pressed. It only happens down the edges, but as you can imagine, when I'm writing a message and delete sticks, therefor deleting the entire message, it's extremely frustrating. Could this be a software issue, or do I need to return the handset. Thanks in advance...
New Contributor
Posts: 2
Registered: ‎02-12-2013
My Device: Z10
My Carrier: Orange UK

Re: Z10 Keyboard problems

Update. It seems to only happen in BBM, texts and apps. Email typing seems to be fine.
Contributor
Posts: 25
Registered: ‎02-07-2013
My Device: Z30 - Z10
My Carrier: Telus

Re: Z10 Keyboard problems

I am having the same issues. I go to delete a letter and deletes teh last 30 words i typed. 

 

I have no answers, I rebooted and it seemed to fix for a bit then it came back

 

 

BB Z30 = Best phone on the market!

Loving the battery life
New Contributor
Posts: 9
Registered: ‎02-07-2013
My Device: z10
My Carrier: telus

Re: Z10 Keyboard problems

Shut off magnifaction. This solves the auto delete thing with the backspace button. Now if someone could just find out why my keyboard refuses to type a message, that would be super... Its happening A LOT now.

New Contributor
Posts: 9
Registered: ‎02-07-2013
My Device: z10
My Carrier: telus

Re: Z10 Keyboard problems

MY KEYBOARD IS COMPLETELY INOPERABLE NOW!!!! Yes im yelling. For help. Nothing brings it back. Reboots, battery pulls, on/off.... nothing. Phone works 'ok' other than that.  Please someone..  how do i go about a wipe and reload if thats my next step at this point.... not happy BB. I live in a house with 4 iphone users and I look ridiculous right now. 

New Contributor
Posts: 9
Registered: ‎02-07-2013
My Device: z10
My Carrier: telus

Re: Z10 Keyboard problems

Cannot even do a wipe because i cant type "blackberry" to prompt the security wipe. Wicked. I'll try one more device because im stubborn, then im done with BB.

New Contributor
Posts: 9
Registered: ‎02-07-2013
My Device: z10
My Carrier: telus

Re: Z10 Keyboard problems

Just deleted all of my texts, emails, pictures, etc because I couldn't wipe it before I return it for an exchange...and yep, you guessed it. Works fine now. THOR???? Wipe in progress. Might as well try to return it instead of restoring this one even though they are going to say "whats wrong with it" and i'm not going to be able to duplicate the problem. Not impressed.

New Contributor
Posts: 4
Registered: ‎02-16-2013
My Device: Blackberry Z10
My Carrier: EE

Re: Z10 Keyboard problems

Right i have figured out why this happens!

 

You need to switch off MAGNIFY MODE which is located in the accessibility within settings.

 

So go into settings > accessibility > magnify mode OFF

 

I remember messing about with my phone and enabling this function.  Thinking it was a good idea at the time.  

 

Hope this helps 

 

Enjoy

New Contributor
Posts: 9
Registered: ‎02-07-2013
My Device: z10
My Carrier: telus

Re: Z10 Keyboard problems

I can confirm that this DOES NOT fix the problem. Might be part of the reason but not all. The Most effective 'fix' I've found is to clean out the hub. Delete texts, emails, bbms etc. Ive had so many freezes that its getting unbearable. Took all of my willpower not to throw this phone into traffic yesterday. A restart will sometimes temporarily get you up and running again, but ive found that cleaning the hub out works everytime.

New Contributor
Posts: 4
Registered: ‎02-16-2013
My Device: Blackberry Z10
My Carrier: EE

Re: Z10 Keyboard problems

The problem I faced was when typing BBM's, Emails etc, the letter A, P and the Backspace were sticking and in turn would delete all the text.  By turning this magnify feature off it solved the problem for me.

 

It sounds like you have a more serious fault.

 

Good luck